Simscale meshings and simulations

I am making a project to simulate airflows in one of the rooms at my school, but when i do the mesh parts in simscale it takes so long and does not even get past 0%. I decided to use standard instead of hex-dominant. I have a community/academic account so i can not go past 16 cores. I have been on this issue since yesterday, I am doing the project : SimScale

I was trying to have this running by tomorrow at the latest, so i can at least know how to go on further.


The issue that you are running into is related to the geometry. Although the geometry looks very clean, there are a total of 8 small faces in the geometry, causing the mesh size to get very large (small details take very fine cells to capture):

Up-close, it looks like this:

I recommend deleting these fillets in your CAD tool, and re-importing the geometry. This should allow you to obtain a mesh with a reasonable size.


So I had to go into the original cad and make sure the ceiling and walls touched the outside part of the walls when I loaded it in. I had to make an enclosure because it kept saying an infinite flow volume for a closed inner region error THEN I had to make the closed inner region. I did not know I had to do that. I do not see the fillets now, I will report back and see how it worked out sometime tomorrow. hopefully, I can actually simulate and mesh something.
Thank you so much!

Oh how cruel fate is, I made the edits and tried to use Onshape for the first time today to work on the project. I had to rename is and currently I cleaned it up to a point where the fillet issue from last time is gone, i made the fineness less than 5 but it still does not run or gives an error. I thought that this should work by now? I got this error in the mesh log for the simulation “CHT using onshape edit” :
"Maximum precision of model and its entities: 1e-08 m.

Absolute small feature tolerance: 9.99998e-06 m.

Gap refinement size is reaching lower cell size cap for 0 faces. Consider lowering model tolerance if resulting mesh fineness is too coarse.

Code: 804 String: Mesh settings may be too fine: please inspect your settings"
Do you think i shuould scale my model down some and see if it can run better?


The mesh was failing due to additional fillets around the inlet faces, which I hadn’t previously spotted:

In any case, I believe you also were able to spot the problem in the meantime, as you have uploaded a new geometry without the fillets. The new geometry seems to be running smoothly, as I can see successful meshing and simulation operations, which is awesome!


1 Like