Serpentine Nozzle not having proper flow

I’m facing difficulties while setting up a Compressible flow simulation through a serpentine nozzle. All of the boundary conditions have been obtained from a research paper and the initial conditions have been calculated and verified. There are no issues with the meshing process either, but somehow, no matter what I try I always get the same result, Temperature deteriorating from 2000K to 200K within a few mm after entering the domain and almost no flow velocity at all.
Any assistance would be appreciated.

Simulation Link-[SimScale Login]

Hi eddie3,
Firstly, interesting to see your project and I’m a newbie, but I see the project’s Initial Temperature is set at the default of 19.85 C degrees. Maybe this needs to be changed?

1 Like

Hello eddie3.

Please go ahead as sugessted by ChuckMulder and set the initial value for the temperature field to 2000K ´. I did a test run where I only change this setting and it worked. The issue was that the temperature field was to far of from the initial values than the boundary condition which makes it hard for the field to converge.

Best regards
Sebastian

1 Like

Hello,

I have tried setting the initial temp to 2000K, however I keep getting the following error-
Maximum number of iterations exceeded when calculating temperature from a thermodynamic potential.

Could you please link your simulation and guide me further.

Thanks

Unfortunately I cannot share the project with you.

Could you try to do the same run again with the velocity inlet condition?
Also can you share the link to the research paper with me?

Hi eddie,
I see @SBlock verified the underlying cause of the simulation temperature deviation error. The current issue arising is related to the settings in the Simulation control area, that will need to be adjusted.

I had a look at the last project simulation “Copy of Validation” - Run No12 in the saved setting area. The previous simulation time was set to a maximum runtime of 3,000 seconds. To allow the simulation to go longer you can increase the " Max runtime" to a maximum of 30,000 seconds. Equally, consider increasing the “End time” setting of 1,000 to possibly a longer time period if convergence has not occurred.