Results disapear in a Shock test


#1

Hi all,

I am developing (or trying at the moment…) a shock test simulation and, since it is my first dynamic simulation I am facing several problems with the setup. However, my question is not related to the setup itself but with the loss of the results after the simulation is carried out, apparently without any error during the run. The simulation is called Dynamic_shock_coarse_3 and the run is Run 1_32/8_BC_simplified.

As you can see the run worked normally until the last timestep (0.05s) although it took 139 min when the simulation time was defined to be at most 120 min. I understand that the simulation finished with less than 120 min but then it took more time to reconstruct the case and arrange the results. Here comes the big problem because no results are found anywhere! Although it seems not to be any error in the run. I checked the log file and, although I’m not familiar with the Code Aster logs, I didn’t see any problem in there.

The Simulation Run Event Log looks as follows:

Job was prepared successfully.
The specified maximum runtime of the job was exceeded. The simulation run was stopped and potential intermediate results were restored. You can increase the maximum runtime in the simulation control section to enable a complete simulation run.

I don’t think it’s a matter of disk space since it is a problem I already faced and when it happens the Simulation Run Event Log displays the message shown below, which is not displaying in this case.

The instance storage ran out of space. You can prevent this behavior by reducing the number of time steps that are stored by increasing the write interval in the simulation control settings. More info

Besides, only 35 time steps should be stored and the mesh properties are shown here.

**Mesh Properties**

Nodes                  180228
1D elements (edges)    14620
2D elements (faces)    253540
3D elements (volumes)  681385

The problem of missing results after an apparently right run is something I have faced more than once in this simulation. Another example can be found in the run Dynamic_shock_coarse_3 --> Run 1_32/8_5e-2/var_newton-tol_1e-4_pen-coef_1e12.

I need some help with that since I am wasting a lot of time (simulation time and real live time) with this simulation and I can’t afford to keep losing the results after a run is made.

Thanks in advance.

Alex


#2

Hi @alexroque and thanks for your detailed response!

I have copied the project and saw that the run not giving you any solution fields in the post-processor was cancelled due to the following reason: “The specified maximum runtime of the job was exceeded. The simulation run was stopped and potential intermediate results were restored. You can increase the maximum runtime in the simulation control section to enable a complete simulation run.” So by increasing the maximum runtime the “error message” should vanish and you can have a look at your post-processing results.

On top of that I saw that there are two small components not being attached to your CAD - is this on purpose?

If I did not get your problem correctly or need any further assistance please let me know and I will jump in again. Also tagging the other @PowerUsers_FEA here for any further tips and hints regarding your setup.

Cheers,

Jousef


#3

Hi @jousefm, thanks for your quick response. After your answer I gave a quick look to all of the simulations I have carried out so far and I noticed some interesting things, actually, I think I may have detected a bug. I’ll explain what I have found.

Some of the tests I have done have eventually stopped because of the maximum runtime specified (2 hours) without reaching the final time step. When it happens the following messages show up.

· The computation was canceled either by a user request or due to the maximum execution time being exceeded. Trying to recover intermediate results.
· The specified maximum runtime of the job was exceeded. The simulation run was stopped and potential intermediate results were restored. You can increase the maximum runtime in the simulation control section to enable a complete simulation run.

Notice the statement bolded.

However, in the case in which I have lost the results, which finished the computation correctly until the end within the runtime specified, only the last message is displayed, not the one I marked in bold letters. So I understand that the results have not been recovered, which makes no sense to me since the run finished correctly. It seems that it took a while to prepare the results or something like that so the process was killed somehow before the results were correctly saved. Am I right?

Regarding your comment about the 2 cylinders, they are there with the aim of limiting the travel of the system after the impact of the hammer from below. Note that there are 2 more cylinders under the anvil that prevent it from falling down. I also tried to use elastic supports but I thought it would be better this way, more realistic. Do you consider it as a good approach?

Let me know if what happened here is due to a bug or something similar since I don’t undestand why I lost all the results in this case after finishing the run without a problem. Now I run the same case again extending the maximum runtime a little bit in order to see if I can get the results this way, I will keep you updated.

Thanks for all!

Alex


#4

Hi @alexroque and sorry for the delay!

The thing is that the simulation has two steps and times out in the second step which is kind of unfortunate.

Maybe my colleague @rszoeke can give you some more information why this happens and how you can overcome that issue.

Cheers!

Jousef


#5

Hi @alexroque,
essentially there are two different problems with your failing simulations.

The first one regarding the results not being recovered when the analysis gets canceled.
In this case you are basically just “unlucky”.
The simulation is basically carried out in two steps, the first one being the actual setup and solving of the equation systems and then in a second step we compute the derived results (stresses at nodes, strains, reaction forces, create result plots, etc.). The second part is usually just a fraction of the actual simulation (<5%). If a simulation fails, or gets canceled, the main simulation step is stopped, but the post-processing is still carried out (that’s where you get the message “trying to recover results”.

In your case it just happened that the actual solution step was already done and the post-processing step was already started at the time where the timeout happened. So this was stopped and no additional “result recovery” step was tried. I reported this bug, so that in future we will not stop the calculation if the post-processing step is already started.

Regarding the run time being larger than the 120 min max specified time, the reason is the following.
If the time limit (120 min in your case) is reached, the calculation is canceled immediately, but to allow the solver to actually recover the results, we added some time buffer (~10 min to be safe for large cases) for which we allow the result recovery to take place - otherwise no results would be available for any canceled simulation.

Finally your issue regarding the limited instance storage space, this is something we will need to take a closer look at, as I agree that storing 35 time steps with the mesh you had (~200K nodes + ~700K elements) should be easily possible with the storage size we provide on the instance.
Until this is fixed I can only advise you to remove unnecessary fields from the solution fields under result control and reduce the result storage frequency in the simulation controls.

I hope this helped. Don’t hesitate to reach out to us in case you have any further issues.

Best,
Richard


#6

Thanks a lot @rszoeke for your detailed explanation! That helps a lot.

By the way, I re run the problematic case extending the run time to 9000 sec and I had no problem recovering the results.

Thanks for reporting it as a bug, it will help if it gets solved in the future! :slight_smile:

regards,

Alex