SimScale CAE Forum

Refinement is not effective


#1

I am trying to do the simulation of turbulence flow inside a pipe. So, I would like to do inflation boundary layer refinement.

But after the mesh is generated, I cannot notice the refinement at all.

Thank you in advance!


#2

Hi @Chotirawee!

Can you share the project with me? Not sure if that’s the one which is public on your page. If you want to add a refinement to your mesh and the meshing process has already been performed you have to first “Delete the Results” in order to add other refinements to it. If you tried that please share the project as well so I can give it a spin.

Best,

Jousef


#3

@jousefm
Yes, the pipe one that’s one my dashboard.

I will try to share my project now (have not done it before)

After I share it, can we create new mesh and do the refinement on the new one because I don’t want to remove my results.

thank you very much


#4

Hi @Chotirawee!

You can have a look at this project in the meantime to see how it is done: Turbulent Pipe Flow Validation. You can simply copy the project and adapt the boundary conditions to your needs.

Best,

Jousef


#5

@jousefm
I am actually learning from that validation and try to do the same thing until I got stuck with this problem, Hahaha…

By the way, can you already access my project ? because I’m not sure if I share it right


#6

Hi @Chotirawee

I see a project called ‘Validation pipe’ on your public dashboard but there are two meshes.
‘Mesh lamina’ has no attempt at layering as shown in your first post.
‘Mesh turbulent’ is imported and is layered.
Have you deleted the attempt at layering in your first post?

Thanks,
Dale


#7

Hi @DaleKramer

Yes, exactly
I was first trying to generate mesh with inflated boundary layer refinement. But after failing several times, I decided to import mesh from the validation case “Turbulent Pipe Flow Validation” in order to continue doing simulation.


#8

Could you please attempt the layering and leave it in the state of 1st post?

Thanks,
Dale


#9

@DaleKramer

Okay I will create it again now.
thanks


#10

I am watching :wink:


#11

Aha, now I think I see the issue, try it with ‘Use relative layers’ set to false…

I think it just did not create the relative layers you asked for because they would have been too small compared to the surface cells that your meshing created.

If you really wanted those very small relative layers to be created, then I think you would need to add a surface refinement set to say Min and Max level = 7 or more until they ‘appear’ on the mesh…

EDIT; I see it worked :smile:


#12

Wow, it works!!!

Thank you very much :smiley:


#13

Thanks for jumping in here and helping out Dale! :+1:

Cheers,

Jousef


#14

Hi everyone,

Just to chip in, you can use the automatic meshing options such as the “Hex-dominant automatic” algorithm which will allow for quick, easy and relatively high quality meshes on simple geometries.

To get the inflation layers to show up however for this pipe geometry, you need to leave the inlets and outlets unselected. Of course, don’t forget to select allow inflation layers as well.

Cheers.

Regards,
Barry