SimScale CAE Forum

Problem with mesh generation and lift and drag values


Basically I am comparing Blended Wing Body (BWB) aircraft to conventional aircraft (such as Boieng 737) and am expecting lift-to-drag ratios of the BWB’s to be higher than that of the conventional aircraft. I am also using ParaView to visualise the data and get lift-to-drag ratios.

I have created my own project in SimScale called ‘BWB testing no1’ (it is shared with support), and I have managed to get a good convergence plot with residual values down to 1E^-6. However, when I open the data in ParaView, my model has very rough edges and is not very similar to the original model - why is this? Could it be a problem with the mesh generation in SimScale?

Also, as you can see in the attachment (‘Paraview BWB’) in the top right corner, I am getting a lift value much smaller than the drag value, and the lift should really be higher than the drag. Why might this be and how I can fix it? I really need and appreciate any help as I do not have long to finish this. Thank you!

Here is a link to my project:

Hi @DylCG10

This is because your mesh is not refined enough to conform to the geometry.

Try increasing the refinement level on the aircraft only, (you could try hex-preview to do this automatically). You could also try using a half model, and applying the symmetry condition to the symmetry wall in the simulation, this allows you to use half the cells for the same results.


1 Like

Thanks for your reply, was just wondering if you meant the ‘hex-dominant (beta preview)’ option in the mesh generation section? Thanks.

Hi @DylCG10, yes that one, it should give a nice blend of automatic and manual controls, so if you need more control (refinements, moving the bounding box etc) then that should be your solution, otherwise for full control of the mesh you might need to you hex parametric.


Hi Darren,

What exactly do you mean by the symmetry condition and the symmetry wall? I will probably have to try using a half model as I am getting errors when I try doing hex-preview. I am also only able to do a fineness level of ‘moderate (3)’ otherwise I get an error message that ‘the machine ran out of memory’.

Yeah I’m also unable to use the hex-preview setting as I keep getting errors during the mesh generation and when I try using a different file type, it says that ‘there was an error importing the file’. Also, when I increase the fineness above moderate, the machine runs out of memory. I have tried using 16 cores, 8 cores, but it only works when I set the fineness level as moderate. Any help? Thank you!