SimScale CAE Forum

Optimizing mesh quality and Y+ layer formation on an FSAE car


#281

Its not that i dont want to use 3.4. I just thought if the lowest we could go was maybe 2.8 or something then we could fit a second layer and get the best of both worlds


#282

I have run it already, i can try it again and see if that works


#283

Any chance you have a 32 bit computer?


#284

pretty sure i dont, im running the new paraview wich is 64 bit
image


#285

Most likely the ocx didn’t register, here is a debugging thread for that, I know the setup zip should include the ocx, then we just need to get it registered and then find out why it did not register when setup exe was run…

Otherwise it is something else :frowning: causing error…


#286

ok i think the ocx is already there. when i tried to extract to theSysWOW64 it asked to copy or replace


#287

It could be there and not registered, try the regsvr32 command with admin rights… then it will tell you if it registers…

If it has registered then maybe it is a language/windows setup issue :thinking:


#288

so run this as administrator? sorry im terrible with coding / hacker level computer stuff haha
image


#289


.
And here:
.


#290

I have to find a computer around here that I have never ran yPlusHistogram on it before and see if I have same issue…


#291

I tried both and the 32 bit one had an error, the 64 said it cant the path

It could be the language issue. Or maybe that im running windows 7? i have no idea


#292

Change directory in the terminal window using cd c:… to the dir where the ocx is, then type the command without any of the % items…


#293

Is this what you mean? the OCX in the same place as the program? I have no idea :sweat_smile:
image


#294

Relax, I have duplicated your error on a new computer, I will debug this and get back to you here :wink:


#295

ok haha, i was about to call an ambulance. Its late here and my head was about to explode. Thanks a lot for troubleshooting!


#296

Darn, I think all it was, was that I forgot to take it out of debug mode when I compiled the project…

I had to make it version 205 now and you can get the setup file for 205 here

Run that setup program and the replace all yPlusHistogram.exe files that you have put anywhere on your computer (like in the browser downloads directory) with the new yPlusHistogram.exe…

Sorry for confusion, brain fart I hope, let me know if it works now?


#297

Success!! This is the plot from the full car simulation

  • 1 layer BL at 3.4mm
  • 1000 iterations - it seems i should have it run longer, it did not reach 1% stability

The Y+ histogram log is still running but so far it looks good. Ill update the final histogram when all faces are accounted for.

Edit here is the final result - 30mb file, had to wait a bit


#298

also on and off i am getting this error. When i re-click on the yplus_area.csv in the histogram program to re-calculate the Y+ it shows up. Not all the time though. When i click ok on the error box it closes the program but when i reopen it, it works agian. Just thought id let you know.


#299

Only way I can debug that is for me to have the exact yplus_area file that has just been clicked on when the error happens…
Do you have a way of uploading the 30mb file to the web somehow and then put a link for access to it here?


#300

yes i can make a dropbox file with the link in the file and share it with you, does that work?