No sign of convergence


#1

https://www.simscale.com/workbench/?pid=533448612645742653#tab_1-0
in this project i have been trying to run a cfd simulation and i think my mesh is wrog can some one look for me.
“copy new truck wind” is the proect


#2

Hi @sjay

I think it is better to add boundary layers on surfaces of a floor and a car body.

Best,
Yosuke Yamamoto


#3

i did


#4

Hi @sjay,

If you look at the meshing log you will notice this.

Undo iteration 0
Checking faces in error :
non-orthogonality > 70 degrees : 0
faces with face pyramid volume < 1e-13 : 0
faces with concavity > 80 degrees : 0
faces with skewness > 4 (internal) or 20 (boundary) : 0
faces with interpolation weights (0…1) < 0.02 : 0
faces with volume ratio of neighbour cells < 0.01 : 0
faces with face twist < 0.01 : 0
faces on cells with determinant < 0.001 : 0
No layers to generate …
Layer mesh : cells:7924616 faces:24008553 points:8160751
Cells per refinement level:
0 449962
1 49012
2 1798665
3 5626977
Writing mesh to time constant
Wrote mesh in = 15.23 s.
Layers added in = 15.23 s.
Checking final mesh …
Checking faces in error :
non-orthogonality > 70 degrees : 0
faces with face pyramid volume < 1e-13 : 0
faces with concavity > 80 degrees : 0
faces with skewness > 4 (internal) or 20 (boundary) : 0
faces with interpolation weights (0…1) < 0.02 : 0
faces with volume ratio of neighbour cells < 0.01 : 0
faces with face twist < 0.01 : 0
faces on cells with determinant < 0.001 : 0
Finished meshing without any errors
Finished meshing in = 582.26 s.
End
Finalising parallel run
Surface Element Quality Metrics
Area Max: 0.0840737, Min: 3.32753e-05, Avg: 0.005857160694420933
Aspect ratio Max: 5.65687, Min: 1, Avg: 1.2980385234569451
Skew Max: 0.934434, Min: 0, Avg: 0.0005966593537191546
Scaled Jacobian Max: 1, Min: -0.486532, Avg: 0.7023210717088404
Condition Max: 5e+29, Min: 1, Avg: 2.1348467696282437e+24
Volume Element Quality Metrics
Volume Max: 0.0241983, Min: 1.13377e-05, Avg: 0.00147433
Skew Max: 0.843226, Min: 0, Avg: 0.0014932
Scaled Jacobian Max: 1, Min: -0.465943, Avg: 0.999901

Your layers are not being generated. You will need to move to the other meshes where there are layers (check the log as well) or use the parametric option.

Cheers.

Regards,
Barry


#5

i tried to mesh with layers early nd i saw that box behind got a leak and meshed inside


#6

Hi @sjay,

Then you clearly need to fix your geometry in CAD before uploading.

Cheers.

Regards,
Barry


#7

Hi @sjay

How about using ‘GAMG’ for pressure solver.
You are using ‘Smooth solver’ in your simulations.

When I changed p Solver from ‘GAMG’ to ‘Smooth solver’ in my project, that convergence plots got wrong as shown below.

The ‘GAMG’ solver for pressure works fine in my project.
https://www.simscale.com/workbench/?pid=2190444917255798374#tab_1-0

Regards,
Yosuke