SimScale CAE Forum

Meshing Warning

I’ve been busy attempting to run simulations for research. However, I’ve been having issues with my attempts at running my private simulations with the geometries I created. I keep getting warnings saying,

“the tesselated surface is not closed. There could be a problem with the CAD geometry (such as self-intersections). Please inspect your geometry. Trying to proceed anyway.

At first I had a more detailed model of a vehicle. I could never get past the meshing stage. Then, I made a dummy model with almost no minor details. I had the same errors. So, at this point I’ve gotten really frustrated with the issue because the mesh never generates but still attempting to solve the issues to finish my simulations this weekend so I can continue on with my research. If you are able to help I would greatly appreciate it.

Project linked below

Hi @rgutierrez852, I’m new to meshing on this platform too. Looking at your model the first thing I see is that your “Solid_3” encompasses the rest of your model. Also one face of Solid_3 is coincident with the model. The first issue will cause you to lose all geometry of the vehicle and the second is likely causing it to fail. So go ahead and try to import the model without Solid_3 and then use the “background mesh box” geometry primitive to create the fluid volume around the vehicle.

I learned a TON about meshing from this workshop. One of the big things was all the details that can make an otherwise valid looking simulation totally wrong.

1 Like

Hi @rgutierrez852!

First of all thanks a lot for the detailed description of your post. Regarding the model I would just upload the car without the box surrounding it. You can let the mesher do the job and create the bounding box. The problem is that your box is too small anyway so I would not even attempt to mesh it like that.

So just take your CAD, upload it and then define the flow domain, simple as that. And you can even use half of your car as it is symmetric. Let us know if you have any questions.



1 Like

Thank you very much @jhartung. The video was very helpful for understanding meshing in SimScale. I appreciate your input.

1 Like

Hello @jousefm thank you for your input. I was also wondering if it mattered if my wheels were separate bodies from the main car body, if the program will still recognize that the wheels are a part of the geometry in question. I’m concerned that even if my material point is outside of my car body that it will mesh inside of the wheels as well.

Hi there!

Yes, that’s absolutely fine. The problem often is that the CAD model is not watertight - but if everything is closed and you set the material point to be away from the car and inside the bounding box it will produce the results you want. :+1:



@jousefm Thank you again. It’s been a very stressful time for me just because I’ve had alot going on lately and you have been very helpful throughout this whole process.

@jousefm also one last question. My geometry never loads on the screen when I’m setting up a simulation so I’m kind of left guessing which faces are which. Any idea what’s happening so I can see what’s happening?

Absolutely no problem, that’s why we are here :slight_smile:

Do you mind sharing a picture with us to see what you mean? How fast is your internet connection?




See how I just get a blank screen where it says loading in the bottom left corner?

Internet speeds look to be 143 Mbps download and 239 Mbps upload.

@jousefm If I have no boundary box physically imported then how do I select inlets, outlets, and material volume if I can’t select the boundary box created in the mesh section?

Hi @rgutierrez852.

Can you try switching to Chrome? :wink:



1 Like

So I’ve started a new project with the fixes that you both have been recommending. However, still getting the same warning messages that I started with.

Hey @rgutierrez852 next step is to look at your geometry. Maybe the warning is correct? I found this little face that doesn’t look intentional. Try correcting those.


@jhartung You are the best. After removing that little loop everything started working. Thank you so so much.



Yay! Sometimes it just takes another set of eyes. Looking forward to seeing more results.

Four eyes see more than two, great job @jhartung! :slight_smile:

Let us know if you have any further problems @rgutierrez852.

Good start into the week!


1 Like