Meshing problem


#1

Hi all,

I am facing some problems during the mesh creation. The geometry has been created in OnShape and exported as a STEP. The fact is that since July I have been working with a geometry created with the same procedure without any problem, but now I did some minor modifications on the geometry and now the mesher complains like this:

A problem occured in surface mesh generation. Retrying meshing with quadrangle surface elements disabled for the following solid: B24_TE28463

I tried some slightly different geometries, modified from the original mesh that worked, and all of them give me the same error but changing the name of the “supposed solid”. And I say “supposed solid” because there’s no solid named like that in my geometry…

Another thing I tried is to import directly the geometry from Onshape, which gives out the same error. This time, however, in one of the trials it points out to an actual solid of my geometry. A solid that hasn’t suffered any change from the previous geometry iteration… Below you can see the original geometry and the modified geometry:

Original geometry

Modified geometry (and the unchanged solid that triggers the error in a test)

What can I do to skip these problems and get the mesh done?

Thanks in advance.

Alex

Edit: I already watched this video by @BenLewis but I couldn’t figure out what can be happening since I don’t use Solid Works but Onshape. Is there any tool like Geometry Analysis in Onshape?

Besides that, I also tried to remesh the original mesh again so as to check if there was a problem with the mesher itself, since a lot of changes have been introduced recently and maybe some of them introduced some bug to the mesher, but the mesh of the original geometry keeps working fine…

I also thought that it could be a problem with Onshape, maybe some software update from July on affected the geometry generation internally somehow. Do you know if it can be possible?


#2

Hi @alex_roque,

I am trying to identify the cause but could not find anything so far. If I am not mistaken you could use feature scripts on Onshape to check your geometry but I never tried it tbh. Darren (@1318980), do you know if these scripts also work for FEA because for CFD they do for sure. Inviting the @PowerUsers_FEA here, maybe they have a good solution on how to efficiently check geometries with Salome or anything else.

Best,

Jousef


#3

Hi @jousefm @alex_roque , yer feature scripts can do pretty much whatever you want them to do, but beware, because they are features you could create a script that says, queries all small faces, a large geometry will take ages, potentially time out and will do the operation upon every re-generation, so you need to delete it once you have found what you are looking for.

Best,
Darren


#5

Hi @alex_roque,

there seems to be some issue with the refinement you have chosen. When removing every refinement I get a coarse mesh without any error messages. I will try to increasingly refine the mesh later on and let you know about my progress.

Best,

Jousef


#6

Hi @jousefm,

thanks to your information I developed some tests reaching the same results as you, that is to say, by removing all the refinements I can get a mesh no matter what geometry I use. Which is not very useful since I need the refinements. After that I carried out some other tests so as to try to find out a solution to this issue I am facing, with no luck I am sorry to say…:disappointed_relieved:

I will list all the tests I have been doing so as to shed some light in order to solve the problem:

  1. Mesh from NEW geometry (STEP) without any refinement/coarsening: OK it works
  2. Mesh from NEW geometry (STEP) with ANY refinement/coarsening: FAIL no matter what refinement/coarsening I use. In the original mesh I used 4 diferent refinements/coarsenings. I tried all of them one by one applied to the same parts and the error I get is the same for all. Besides I tried to apply a refine to only one part reaching the same result.
  3. Mesh from NEW geometry (Imported directly from Onshape) with refinement/coarsening: FAIL. Same as 2 (I only tried to get the mesh with all the original refinements, I didn’t try to add the refinements one by one).
  4. Mesh from ORIGINAL geometry (STEP) uploaded in July: It works exactly as it did in July when I first meshed it.
  5. Mesh from ORIGINAL geometry (STEP) reuploaded today: FAIL. Same as 2 (I only tried to get the mesh with all the original refinements, I didn’t try to add the refinements one by one).
  6. Mesh from NEW geometry (x_t) with all the refinements: FAIL. Same as 2.
  7. Mesh from NEW geometry (IGES) with all the refinements: FAIL. The geometry itself seems to be uploaded with some error since the Geometry Event Log reports the following messages:
    Geometry import reported body check errors. In case you face issues in meshing consider cleanup operations in your CAD tool.
    Number of small faces: 2
    Number of open shells: 36
    Geometry is not watertight.

After all these tests I realized that the Geometry Event Log and the Mesh Operation Event Log now give slightly different information compared to July. Besides that, now the uploading process respects the original part names, which is something very helpful. However, all these changes in the geometry handling make me think that something might have changed for bad during the software update you did in the platform causing these problems with the refinments. What do you think? Have you noticed this problems before or heard from someone else’s experince?

I really need to solve this issue to be able to carry on my simulations. I hope my inputs can give you valuable information in order to solve it.

Thanks in advance.

Best,

Alex


#7

Hi @alex_roque!

Exactly what I experienced as well with the refinement ON/OFF approach. @yosukegb4, can you see if there is some kind of overlap or corrupted component with Rhino? Unfortunately I did not manage to get a tool on my machine so far (shame on me) to check weird behavior of CAD models. Maybe someone of the @PowerUsers_FEA can help out here. Also tagging my colleague Richard (@rszoeke) here who might give his two cents on this issue.

Best,

Jousef


#8

Hi Darren (@1318980 ),

Can you tell me where I can find this feature script you talk about? I am looking for it right now but I can’t find it!

Thanks in advance.

Alex


#9

Hi @alex_roque,
I think we found the issue. I just filed a bug report. There is indeed an issue with refinements on Tet-Dominant meshes with newly uploaded geometries (where we would use our new CAD kernel).

I will let you know as soon as I have any updates.

PS: To unblock you, if you like, I can upload your model to the project using the old kernel. Just let me know which CAD files and I will do it on a copy of your project.

Best,
Richard


#10

Hi Richard,

Thanks for the feedback. It would be nice if you could upload my geometries with the old kernel, how can we do it? How can I send you the geometries so that you can upload them?


#11

Hi @alex_roque,
no need to send me the geometries they are already uploaded to the project. If not please just upload them.
I would only need the names of the geometries which you would need to be re-imported.

Best,
Richard


#12

Ok, the geometries I need are the last 3 that I just uploaded, the ones finished with _r2


#13

Hi @alex_roque,
here is the project with the leswt 3 geometries re-uploaded using the old kernel (you can notice this by the different names of the solids, with the new kernel we can directly show the original CAD names): https://www.simscale.com/projects/rszoeke/loudhailer_vibration_analysis_advanced_-_old_kernel/

I tried to mesh the first of the three and it worked just fine:

Best,
Richard

PS: let me know if I should upload any additional files until the fix is released.


#14

Thank you so much @rszoeke, I’m copying the project right now! :grinning:

Let me know when the issue is fixed!


#15

Hi @alex_roque
Thanks for reporting this issue! I have just pushed a fix to the live system which ensures that the mesh is created correctly with the new CAD backend as well. Feel free to try it out and report back if there are any problems.
Hannes


#16

Hi @jprobst,

I just tried it and it works perfectly! Thanks for the quick solution! :smiley:


Harmonic analysis without stress results
#17

Hi @jprobst

I will reuse this thread to mention a kind of bug I am facing since you fixed the problem with the meshing algorithm. Although now I can mesh my geometries without a problem, now it produces infinitesimal faces where there should be edges, resulting in a distorted mesh in these areas and affecting the accurateness of the results. Here comes the problem.

My geometry (conflictive edge in red)

Detail of the edge (original)

Detail of the edge (after the fix)

As you can see, the edge is converted into a very tiny face, which enforces the creation of very distorted and sharp tets and a refinment around these edges. This fact in the end turns into poor accurateness results in this area as you can see in the picture below.

What can you say about this issue?

Thanks in advance

Alex


#19

Hi Alex (@alex_roque)!

Will forward your observations and one of my colleagues will reach out to you as soon as possible :slight_smile:

Thanks for your feedback by the way, we appreciate that! Feel free to send me every wish/feedback you have either privately or in the forum.

Have a nice day and a successful week!

Jousef


#20

Not a problem @jousefm! Actually I am used to report bugs due to my previous experience with OpenFOAM! Always helping to improve the software and willing to help! :wink: