Meshing problem: To many illegal faces


#1

Hi everyone! :wink:

I’m simulating a formula student car and I’m having a problem to create a mesh without illegal faces. I’m using the settings as used in Formula Student Webinar. Until just week ago or so, I could create a mesh with 0 illegal faces and suddenly, there are always around 600 illegal faces.I tried to improve the geometry, but nothing seems to work. The number of illegal cells remain more or less the same with just a little fluctuation.

-I checked the geometry, removed few intersecting geometries I didn’t realized before (although they didn’t cause illegal faces).
-Cut of a bit from trailing edge of a front wing, because it looked very “coarse” and I even removed the whole
wing.
-Removed or minimized the size of quite complex neighboring surfaces (e.g., area of the upper side of the front wing and the area where it meats with front wing attachment).
-Merged the neighboring faces in CAD which form a single part as STL for the simulation.
-Checked the mesh operation settings
-Ran whole new mesh operation from very begging to make sure, everything is set up as it should be.
-Only thing that appeared to cause a change was to move the the symmetry “wall” in a range of 0.0 to 0.005m (y-direction) either increasing or decreasing the number of illegal faces.

  • I tried a number of different geometries, even the one that had 0 illegal faces before

I’m using Siemens NX 11.0 CAD for desing and Inventor just for conversion of “.prt” format into “stl”. with a resolution set to high.

Here is the link to my project:
https://www.simscale.com/workbench/?pid=1197450909786872616#tab_0-0
It’s “Model mesh v3.1” where the problem appeared for the first time and “Mesh test”, where I tried all of the aforementioned adjustments.

I’ll be very happy for all of the suggestions and help.
Thanks :slight_smile:

Martin


#2

Hi Martin!

I’ve checked your geometry and mesh, so far no glaring issues.

There was an old post about illegal cells here with various quality control settings so try that.

Do let me know how it goes.

Cheers.

Regards,
Barry


#3

Hi @Get_Barried!

Thank you very much for your advice. I’ve tried it and it looks like it helped a bit. I’m down to 355 illegal faces now. But I made a mistake this time. I accidentally let the sidepod refinement too low, so I try to completely remove whole this part, although I think it’s not going to work.


#4

So I removed the sidepod and I was back to 600 illegal faces with the modified setting from the link


#5

Hi @Fabik,

Where did you get this geometry from? Is it the provided geometry by formula student?

Cheers.

Regards,
Barry


#6

No Barry, it’s my own geometry. I was thinking if it’s not better to use STEP instead of STL, as it was recommended by a number of users here in the forum.


#7

Hi @Fabo,

I have had a lot of issues with STL and would typically recommend other formats such as IGES/STEP/Solidworks parts etc.

Regards,
Barry


#8

Hi @Get_Barried,

Sorry I haven’t responded for quite a time, I was busy past few days… So I tried the STEP format, but it didn’t really helped. Today I found out, it was the radiator support part which seals the gap between the radiator and sidepod. It’s the only part, that has neither boundary layer, so I guess that’s the problem. So I increased its size a bit, increased its refinement and also changed the the Mesh settings in accordance with errors written in Meshing log:

Min cosine of face twist: 0.005 -> -1 (disabled)
Min normalized cell determinant: 0.005 -> 0
Max concaveness: 80 -> 180 (disabled)
Min volume ratio
between neighbouring cells: 0.0075 -> 0
Max non-orthogonality angle 75 -> 80
Min cell volume: 1e-13 -> -1e30 (disabled)

The number of illegal faces decreased, but I have no idea how much does this decreased the precision of the simulation. I ended up with about 100 illgal faces, however it is now the simulation that shows error after an half an hour, so I just try it without radiator and hopefully it will work.


#9

Hi @Fabo,

Don’t really see where the problematic run is, is it the same link?

100 illegal faces should be alright but of course further reducing those would be better.

Cheers.

Regards,
Barry


#10

Hi again Barry,

No it’s another run. I had to use colleagues 's account because I almost ran out of computing hours. It’s
“v_4.2” at this link: https://www.simscale.com/workbench/?pid=2454661445024982905#tab_2-0 …when I tried it without radiator (“v_4.2_no radiator”), simulation finished successfully, although there are still around 100 illegal faces in the mesh.

Thank you for your help so far, by the way.

Regards,
Martin


#11

Hi Martin,

Your simulations and runs look alright. Do post-process them and see if the results are realistic.

Cheers.

Regards,
Barry


#12

Hi Barry,

So I did the simulation without the radiator (porous zone) and the results seem to be fine. I think I will try to run the simulation with it someday later this year, but currently I’m quite busy, so I think I’ll be fine without the radiator at this moment.
Anyway, thank you very much for your advice and help. I appreciate it.

Regards,
Martin


#13

Hi,

I am also getting the same problem as Martin.
Up until a few months ago, I could easily mesh my models with around 150 illegal faces and run the simulations successfully.
But now, the same model when meshed with the same settings gives over 2000 illegal faces and the simulation runs stops at around 4% giving a error stating “signal 8 encountered”.
I tried many different settings with the boundary conditions and then with the mesh settings but could not find any solution.
Here is the link to my project.
https://www.simscale.com/projects/varunkotian/carsim_1_1/

Could I get help on this?

Thanks,
Varun


#14

Hi @varunkotian,

150 illegal faces and 2000 illegal faces are significant differences. With some numerical control some of the illegal cells can be “corrected” of sorts and the simulation can run albeit with a certain level of inaccuracy. However as you’ve inadvertently discovered, 2000 illegal faces is much too error filled and you will hit a simulation error without some serious numerical correction that even if possible would result in significant inaccuracy.

There is no other way other than to fix up the mesh which would involve specific mesh related settings or a need to fix up the geometry (the most likely case) or a combination of both.

Cheers.

Regards,
Barry


#15

Hi @Get_Barried,

I completely understand this. But I fail to understand why the geometry which used to mesh and run perfectly would fail to mesh properly and would give an error in a simulation run.

That aside, could you recommend any changes to the geometry or the mesh settings that I should make?

Thanks,
Varun


#16

Hi @varunkotian,

You are using two different geometries. Obviously the first geometry was better due to the reduced amount of illegal cells. You clearly have made modifications to the new geometry and those modifications (assuming that you drafted the new geometry from the old one) are the source of the problem and you need to address those.

I would assume you already know that it dosen’t matter if you have the same exact settings for a slightly modified geometry, problems may still occur like in your case.

With regards to fixing the geometry, the best way is to use some sort of STL fixer and ensure good CAD practices are enforced throughout drafting and modification of the geometry.

Cheers.

Regards,
Barry


#17

Hi @Get_Barried,

I am using exactly the same geometry. The geometry named “67_with_smaller_span_fwing” and “67 copy” are one and the same. I have just created a duplicate .
So I assume that if a the geometry has meshed successfully in a certain setting then it should be possible to mesh the same geometry again using the same settings.

Still I will take your suggestions and try to fix the CAD.

Thanks,
Varun


#18

Hi @varunkotian,

My apologies as I assumed that the geometries would be different. Didn’t expect a duplicate and remesh of the same geometry.

With that being said, have you made any changes at all to anything between the geometries and the mesh? If not, and yet the illegal cell count and overall cell count differ, it is likely due to how snappyhexmesh works where it is a iterative process that may not always end up with the same mesh even with the exact same settings. This is just speculation however and it will probably need more investigation if it is indeed the case.

Is there a need to remesh with the exact same settings? What was your intention? Also yes the geometry will need to be fixed in order to achieve some level of consistency in meshing as your workable mesh still had illegal cells which indicates problems with the geometry. Do make things as simple as possible and that should resolve majority of the issues within the geometry.

Once you have done so you can try to remesh and see if the problem persists.

Cheers.

Regards,
Barry


#19

Hi @Get_Barried,

I have made no changes to the geometry nor to the mesh.

I recently resumed my work after my exams got over. But I noticed that I could not mesh any of my new geometries with good quality.
So, to be sure that the change in quality was not because of the geometry or the mesh settings, I took a geometry ,which I had meshed perfectly a few months back, and tried to mesh it again with no change to its settings. But, to my surprise the mesh quality was bad instead of being nearly the same.

From this, I draw a conclusion that there may have been a change in mesher’s working which may have affected how the geometry is meshed. And this change may have resulted in the decrease of mesh quality.

Regards,
Varun


#20

Hi @varunkotian,

This is a peculiar issue indeed. As mentioned it may be the iterative process of SnappyHexMesh that causes this difference in mesh quality.

Moving on from here, using your old mesh is a good way to keep progressing. If not, additional work to simplify and clean up the geometry will be needed.

Let us know if you have any other issues.

Cheers.

Regards,
Barry