Mesh Unassigning: MRF Zones

I am trying to create MRF zones in a simulation however I’m having trouble doing so with an enclosure. I can assign volumes for an MRF zone but only when there is no enclosure around it. When I put an enclosure around my model, it unassigns and deletes the mesh which gets rid of the volumes I used for the MRF zone. With an enclosure created it doesn’t give the option of selecting any of my volumes anymore like I could before.

This is probably an easy fix, I’m just having trouble figuring this out on my own.

1 Like

Hi, this is Fillia :slight_smile: Can you send me the link to your project please?


I fixed my problem for that but now have a new one. Here is a link to my project:

It says my mesh finished generating but will not allow me to start a simulation. It also says to use the mesh as a domain but if I do that then wants to delete the mesh and assignments I’ve already made.

And when I look at the mesh, it appears that the MRF zones that I have are what was not meshed properly

I still haven’t been able to solve the problem for the meshing error “The mesh could not be generated. Increasing the mesh fineness or adding local refinements to geometrical details potentially fixes this issue. Please contact our support for further assistance.” and I even changed my MRF zone shape and size a little bit to try and fix things. I’m assuming it could have something to do with my CAD geometry somewhere but I’m not sure exactly where this problem is occuring.

Here’s the link to my project:


Having a look at this last link, based on the meshing log, the mesh is being generated, and then fails a final quality check. There are quite a lot of cells in error:

Such big number is likely related to the poor base cell definition:

The base mesh cells should be perfect cubes (or close to that). With the current bounding box resolution settings, the base cells will be very stretched. I’d recommend going through the relevant documentation page and defining better values for the bounding box resolution. This should reduce the number of cells in error.


1 Like