Mesh quality leading to divergence in CFD Simulation

Hi again Igaviano, i made the modification previously mentioned, and revised the geometry again and removed any small faces or sharp edges as much as possible, also refined the mesh even further, which resulted in acceptable mesh quality and maximum aspect ratio of 1000, mesh need further refinement, but generally the solution started stable convergence when decreased relaxation factors and i started getting numbers,
the working simulation is “Third Iteration FVM 2024” , i would appreciate any further advices.

edit: the solution started diverging again after some iterations unfortunatley

Thank you,


Hi @aerodynamics_c,

Thanks for your reply to the previous post (which can be found here).

I’ve moved this conversation to a new topic so that we can better keep track of it. I’ll take a look at your simulation and make some comments later on :slight_smile:


Hi @aerodynamics_c, unfortunately aspect ratio of 1000 will most likely lead to the divergence of your simulation, unfortunately.

A more trustworthy parameter to track is probably non-orthogonality, however. You need to keep it as low as possible and (on the maximum) below 88.

Examining your model a bit more closely, I see that there are still many probblematic small faces that will lead to low quality meshes. Take this one as an example:

On Onshape you can search for small faces with the check quality option. Hiding all parts, this is the highlight I’ve got:

However, another way to look for small features (both gaps and faces) is to search for elements concentration in your mesh, e.g. these ones:

If you go to the mesh quality viewer, you’ll see that they are responsible for a great deal of the lack of quality: