SimScale CAE Forum

Mesh pipe error

Hi everybody,
I was trying to make the mesh with snappy hex of a turbulent pipe.

When I select mesh refinement and select layers, the program do not take my selection. I tried both to select from the viewer and from the list of faces.
I think I am making some silly mistakes but I cannot figure out what.

Thanks for any help:)

Fabio

I think I made the mistake to use a space in the name now it is working:)

@Fabio88, spaces in any names you choose on SimScale should actually not matter. In case this really happens with spaces, please let us know. In that case we should really look into it!

Actually I changed a space in the mesh name and also a “-” (converted in “_”) in the operation name

It worked for one attempt but when the mesh was created I discovered that no layers where created. Therefore I am making some errors somewhere:)

After that, I tried to change the expansion ratio from 1.3 to 1.1 but when I push the button save nothing happen and when I try to leave that page I get the following screenshot:

and if I push yes to save nothing happen again and I can leave the page only if I push no. Which is the same problem I had before!

Today it has been quite a long day for me and I am quite sure I am making some mistake somewhere but I cannot figure out where and why I get this problem:)

Thanks for the patience and the help:)

Fabio

@Fabio88, is it this project: https://www.simscale.com/projects/Fabio88/pipe_flow ?

yes it is this project:)

I made a copy and will check on it. From what you write I don’t see a mistake in the setup…

Thanks a lot.

I am also looking to see if I can identify the problem.

Now it saves correctly but it does not include the selection of the faces. If I push select from viewer or select assignment I do not get any modification.

If I find why I will let you know:)

Fabio

here an example: I am trying also to use automatic snappy hex mesh but I cannot add the face using add selection from viewer

ps: I am using firefox

Hi @Fabio88,

From the snapshot you have posted, it seems you are a selecting the ‘face’ of an already created ‘mesh’ and adding it ( via the ‘add selection from viewer’) to a mesh operation. The problem is, you Can Not assign a mesh face to a mesh operation !

You must first delete the current mesh by clicking on “Mesh Operations” for this mesh and selecting “delete result” from the settings panel (see below).

To Delete a Mesh only:


.

Then you will see the “geometry” only (you may have to re-click on the mesh operation to refresh the viewer). Then “clear” the current assignments if any and then the geometry face can be added by clicking it and click “Add selection from viewer” , then save.

I have tested this on a sample mesh of same kind and it should work.

Let me know if this solves the selection problem.

Best,
Ali.

1 Like