SimScale CAE Forum

Interface in Conjugate Heat Transfer (CHT)

Hai,

For Conjugate heat transfer simulation, I have 2 solid bodies and 1 fluid domain, my question is should we have to give interface manually or the software itself detects the interface?

My simulation is about generator(Solid 1) produces a heat and passes the heat through fins (Solid 1) attached over the generator surface, fins are cooled with the incoming wind.

I have run 3 different simulation settings but still the solution is getting error. I have used low order scheme and also the adjusted the relaxtion factor but still the error exists.

Requesting you to please look at my file and provide suggestion. Name of the project file is “40fins long domain”

Hi @Vinaykumar!

The solver can detect the faces (once defined) and shows them in the solver log as master and slave faces accordingly. @vgon_alves, could you please have a look at the setup and also see if the CAD is suitable for the simulation? Thanks a lot!

Cheers!

Jousef

1 Like

Hi @jousefm,

Thank you for tag me here!
Please @Vinaykumar, do you confirm that is the project that you are referring to? I’ll take a look at this one and give you a feedback asap.

Cheers,

Vinícius

Yes @vgon_alves , that is the project.

Hi @Vinaykumar,

The CAD geometry looks well. The problem seems the Boundary Conditions. You have some faces without seted in your BC. So I suggest you to set all the faces as wall except the Inlet, Outlet, and Interface faces (You probably will need to set two Conections because your geometry is divided by a line.
The Interface faces that I mention are those:

  • Conection 1: [solid_1_face_5 (Master); solid_0_face_5 (Slave)]
  • Conection 2: [solid_1_face_2 (Master); solid_0_face_7 (Slave)]

EDIT1: Invert selection tool will help you a lot to select the Wall condition

Please, follow these steps and let me know if it works for you.

Cheers,

Vinícius

1 Like

Hai @vgon_alves

I have changed the settings that mention and the simulation worked, thank you for the help. I don’t understand that why we need to create interface, I read in the simscale tutorials that interface will be detected automaticaly.

Final question, I took a snapshot of a plane contour, why are they blur?

Hi @Vinaykumar,

It seems like a bug when you have 2 interfaces one over the another one, but in your case I do not know. To me that is working well, look:

EDTI1: Remember to unmark this option when clip your geometry

Please, try to do a new clip and let me know how it goes.

Cheers,

Vinícius

2 Likes