Inflation Boundary Layer fails to Generate


I’ve been having some issues with the meshing of a propeller. The propeller is located inside a cylinder in order to generate a MRF. I want to generate a Hex mesh. Every time I mesh I get a mesh that looks good and can be used for simulation, but the boundary layer always fails to generate. I’ve checked the mesh log and I don’t understand why it fails to generate.

I want to get a y+ close to 1, but the layer still fails to generate. I’ve tried other values for the overall thickness and final layer thickness, but it still fails to generate.

Somewhere I’ve read that sometimes a good solution is to split the faces to make it easier for the mesher to succeed, but I want to make sure that this is the real issue I’m having before doing it.

This is the link to the project:

I’ve generated several meshes with different levels of refinement, but none have a boundary layer.

Any advice would be appreciated. Thanks!


The issue here is rather simple. For the hex-dominant (parametric) meshing tool, there is one parameter named “Layer size”, which controls what kind of layer definition you have:

As the description says, if this option is enabled, the final layer thickness is going to be relative to the size of the surface cells. If this option is disabled, then the final layer thickness size is taken as an absolute value.

Currently this option is enabled in your settings, so the final layer thickness is relative to the surface cells. However, we have a final layer thickness of 4e-4 (which is going to generate infinitesimal cells). You’d get the thickness of your final layer as 4e-4 times the size of the surface cells.

As you can imagine, such small cells are going to have incredibly bad mesh quality, and will be deleted in the process. In short, you can:

  • disable “Layer size” if you are intending to use absolute values (in meters) for your final layer thickness or,
  • Define the final layer thickness with respect to the size of your surface cells.

For more notes, please visit this documentation page.


1 Like

It worked! Thanks. The boundary layer is finally there. That setting makes perfect sense.