SimScale CAE Forum

Importing from SketchUp for Schools


#1

I’m trying to import a geometry that was designed using Sketchup for schools. It seems the only supported export type from Sketchup into SimScale is STL. However every time I import the model it shows 0 for the number of solids. It looks like from the forum people recommend exporting in STEP format which is not supported in Sketchup for schools.

I’m not able to use any program that I have to download - it has to be browser based. Is there any way to convert my STL file to STEP? Or is there any way to export from Sketchup in a way that would work with SimScale?

solids simscale


#2

Hi @twarner,

Sorry I can net help you out with Sketchup but if you are looking for a web based tool to create geometry to import into Simscale I would check out onshape.com. It’s web based and you can get a free account or a student account.

Let me know if this helps or if I can provide any additional assistance.

Good Luck!
Christopher


#3

I tried tinkering around with onshape. It kept giving me error messages with that it “failed to translate”. I did finally get it to export as a solidworks model but then I’m getting an error from SimScale that it can’t be processed.

If possible I’d much prefer to use Sketchup as that’s what my students are familiar with.
error


#4

Hi @twarner!

Can you send me your file to jmurad@simscale.com? I try it later this evening and see if I can be successful.

Best,

Jousef


#5

Sent! Thanks for your help.


#6

Hi @twarner!

Here you go: https://www.simscale.com/projects/jousefm/teststl/ - it is in STL format. If you would need IGES or STEP I think FreeCad will do the job. Got no other program in mind for a sketchup file also Onshape had issues converting the .skp file. Let me know if you’re happy with the one I provided you with.

Best,

Jousef


#7

Thanks for importing that. I appreciate that file being loaded in but I’m really more interested in the process of being able to load my own. FreeCad has to be downloaded so sadly it won’t work for me. I need something browser based.

Are none of the export options from Sketchup compatible with SimScale?


#8

Also in the STL project you sent me it is still showing 0 solids and I can’t create a Tet-Dominant mesh.


#9

@twarner There are many SimScale customers that use Onshape as a CAD system. So if you have the model in Onshape, you can directly import it via the “Import from Onshape” option:

Screenshot_2018-10-30_16-52-53

There is no need to export a Solidworks file. Could you try the direct import and let us know if it doesn’t work?


#10

I don’t see an option to Import from Onshape. Only options are drag and drop or add from files. Am I in the wrong place?


#11

Actually just saw I can move forward without adding a CAD file there. Here is what happens when I try to import from Onshape. “Something went wrong…”


#12

How did you create this Onshape model? From the name of it, it’s an uploaded STL file?


#13

It’s imported from Sketchup


#14

Hi @twarner!

I also could not manage to upload the sketchup file to Onshape for some reason but the procedure shown by David is always applicable. For this particular case I would just use the model I sent you - I guess it is a thing on their side.

Best,

Jousef


#15

Modeling in Onshape is not a solution for me as Sketchup is what my students are familiar with. If they have to learn new modeling software it becomes an impossible project.

Is there not any other way? Is there any way for SimScale to recognize it as a solid? Would any of the other Sketchup export options work with SimScale?


#16

Hi @twarner!

Let me see later on if there is a good way to use Sketchup the most efficient way possible and if there is something like an add-on that is necessary in order to get the most out of it. What really bothers me though is that my brother tried converting it into STL and it immediately worked (and additionally applying the splitting operation on the platform). :thinking:

Cheers,

Jousef


#17

I created a small test case with a model in Onshape. When importing directly from onshape I was able to create a mesh from a solid object. However when onshape exports an STL file and then I import the STL into SimScale it doesn’t recognize it as a solid and thus can’t create a Tet-dominant mesh.

I think there is a bug in SimScale for importing STL files. Have you been able to load other STL files into SimScale and create Tet-dominant meshes?


#18

Hi @twarner!

SimScale only allows volume mesh generation at the moment. So you could give your model a specific thickness and then mesh it with the Tet-dominant operation.

Also tet-dominant meshes are only for structural analyses at the moment, but I guess that’s the purpose of your simulation, right? @rszoeke, do you have additional input to this topic?

Best,

Jousef


#19

I’m trying to create a volume-mesh with the thickness being the entire object. Yes I’m trying to create a structural analysis. You mentioned your brother was able to import an STL file. Did it show up as a solid? Could he create a tet-dominant mesh from it?


#20

Hi @twarner,

for that I would simply use another file format than STL - STL is just the preferred one for fluid flow simulation. It also prevents you anyway from choosing tet-dominant meshing. Do not hesitate to ask if there’s anything else we can help you with or something is not clear enough.

Best,

Jousef