SimScale CAE Forum

Help with mesh generation


I have one test project and I’m having a problem with generating the mesh. It is a square box with air coming into one side and going out on another side.

Here is the picture of the idea:

Every time I got an error: “The geometry could not be resolved properly in the mesh. Increasing the mesh fineness on the respective bodies potentially fixes this issue. Please contact our support for further assistance.”.

I have tried to use more detailed mesh settings (Fine) but again mesh couldn’t be generated. I also tried to set the manual setting for the mesh but I either got the same error or machine ran out the memory.
Also, I have tried to create a mesh with only air inlet in geometry and mesh was created fine. Then I deleted the air inlet part and add only air outlet in the geometry and mesh was created fine. But when I put them both in the same geometry, mesh can’t be created.

I assume that I need to create a mesh refinement separately for air inlet and an air outlet, but I didn’t manage to do that. I could use help with this part.

Link to my test, simulation: “SIM2 mesh error”


Hi @mpilas

Just gave a quick look at your project and here are the tips for your project-

  1. the thickness of the fins is less than 1mm and this feature will not be able to mesh with the current mesh settings. And sorry for this pathetic creativity of mine :joy: :joy:

  2. Assign an appropriate value in the minimum edge length section so that the solver can create mesh on the fins. I would prefer a minimum edge length of 0.5mm in this case



Hi @anirudh2821998, thank you so much for your help. I tried your suggestion but my machine ran out the memory again (16 cores). So I would like to see how mesh refinements would work in this scenario. Any suggestions with this?

Also, I tried to change the geometry to simplify the fins and use a surface with an angle to replicate the fin angle. Again mesh couldn’t be generated (simulation “air angle 2”). If I remove air outlets, then mesh is successfully created (simulation: “air angle 1”). So it turns out the problem is in the air outlets. Maybe I should assign refinements for air outlets? Or maybe it is the problem with the combination of air inlet and outlet?


Hi @mpilas !

Any progress so far? I would assume that increasing the fineness might cause the mesher to run out of memory. You could try that and let me know if this issue occurs, if so I could mesh and run the simulation for you. I would start with a coarse mesh and work my way up from there!

Let us know if you have any additional questions.


1 Like

Hi @anirudh2821998, unfortunately no. I was caught up with some other stuff so I didn’t experiment too much with mesh refinements. Thank you very much for your offer, but I would like to learn how to optimize meshing so I can be more independent in the next projects.

I’m curious how the mesh is working. In mesh settings, if automatic mesh size is selected, will mesher take in calculation mesh refinements or mesh sizing must be in manual?

I was thinking to set automatic mesh sizing with lower resolution and then use mesh refinements (surface refinement) to get more detailed resolution around the fins and air outlets. I don’t know if this is the right way?

Hi @mpilas

I have got the solution to your problem. The problem is with your CAD file format(igs). I made 2 mesh with same refinement and other mesh properties but used 2 different CAD file format(igs and step) and I got different mesh in both the cases. I generally don’t prefer to work with igs format as sometimes the geometry doesn’t remain watertight and imperfection exist in that file format but Step format is a precise CAD format file, which stores every information accurately. Here is the link to the project. The correct mesh is with the name MESH 3.-





@anirudh2821998 thank you so much. It solved my problem and I manage to do a simulation. This will be very helpful for me, really appreciate this. Thank you once more!