Help required for "Memory allocation error"


#1

I am running a static non-linear analysis, during the simulation time, the following error has been encountered,

Memory allocation error. In order to prevent this error, please choose a machine with more computing cores and use less cores for the computation.

However i have tried by changing number of cores to be computing in Simulation Control tree bar.
Like:

  1. Changing Write control definition (tried all combinations!)
  2. Changing Number of computing cores from 8 to 32
  3. Changing Maximum Runtime(s) from 3600 to 1000000, etc

But the issue is not solved yet.

Please do assist me, Thank you in advance.


#2

Hi @kvijayasarathi!

In the documentation it says: “You can choose bigger machine for the analysis. By choosing it, you can provide the solver with more memory under which the analysis can be easily solved. For example, for a bigger mesh i.e. more than a million 3D elements, assigning analysis to 1,2 or probably 4 cores under Simulation Control will lead to this error. Try to assign at least 8, 16 or 32 cores.” Thus mesh size plays a big role and needs to be taken into account for the simulation.

Please share your project with us to have a closer look at this issue and make sure it is set to public.


On top of that , my colleague @rszoeke posted an explanation about this issue a while ago: Memory Allocation Problem

All the best!

Jousef


#3

Thanks for your response.

You said that “You can choose bigger machine for the analysis. By choosing it, you can provide the solver with more memory under which the analysis can be easily solve"
You mean to say that should I use bigger RAM holder machine ?

Does the simulation run at the machine which I use here for simulation or at your(simscale cloud) ?

Regards,
Karthik


#4

Hi Karthik (@kvijayasarathi) and no worries!

Try using a 32 core instance and see if that works and yes, all the simulations run on the cloud and not on your local machine!

All the best!

Jousef


#5

Hello @jousefm,

First of all thank you so much for your time.

I got it and I could run the simulation, its working.

Thank you SimScale !!

Cheers