Group Faces


I want to mesh a car for Formula student. The problem is that the CAD Model (from solidworks) has too many faces.
It’s really impossible to select all faces for surface rifinement and even if i create “topological entity set” with 32 core and a really coarse mesh, the machine run out of memory.

This is a screen of my car:


I checked the other Car published in public projects and they don’t have all the faces like my project.
I mean, with one click they can pick all the carter, all the wings, all the wheel, without losing details about shape, profile and so on and without define a topological entity set.

I hope that you understand what i am saying.

How can i solve it? I would like to simplify my geometry like they did.

I saw the Solidworks simplify tools for simulation, but it raise features…

Hi @cecca98 and sorry for the delay in my response.

Would you kindly share the project that is affected? We will have a look at that and see how we can overcome this issue the most effective way.



I shared with you.

As you can see, the geometry has really too faces and the meshing operation run out of memory (i think cause of the complexity of geometry).

I though to upload the file in stl format, but i m not able to split faces cause i don’t know a program that do it (simscale can’t do with the feature “splitting faces”).

Hi @cecca98!

I am not satisfied how the geometry looks like. You already imported it with a background box which is kind of odd and I would not do it that way. Upload the model as a standalone model and make sure to group faces inside SolidWorks if that is even possible. You can also create separate STL files and merge them which is demonstrated in this workshop here: Merge STL - FSAE Workshop.

This is the approach I would choose. Maybe @vgon_alves or @Get_Barried have another tip for you.



Yes, i have to delete background box. I didnt know that simscale has a feature to create the “wind gallery”. Anyway i will try this Merge Stl method.

Thanks you for supporting me

Hi again @jousefm,
i follow the merge method (from solidworks).

It works really well and now i have a simple geometry splitted in all of its part.

The problem is: the car is a mess. Parts are not in the right position. Do you know what it could be?

Hi @cecca98 !

For SolidWorks the following two “tricks” might help:

  1. Try ticking off the option “Do not translate STL output data to positive space
  2. Another user already has given a good instruction on how to overcome this problem
    —> SolidWorks - Coordinate System

Let me know if that helped!