SimScale CAE Forum

FSAE - Failed to run CFD simulation


#1

Dear Support,

I am trying to simulate new diffusor for our FSAE car. For now simulations went good but when I uploaded geometry Formula_8 and tried to simulate it, then occurred a problem. Simulation did want to start and solver log does not give me any clue what went wrong.

Link to my project: https://www.simscale.com/workbench/?pid=1237587855504468150#

Could you please help.

Have a nice day


#2

Hi @sengineering!

I could neither find a mistake in the simulation setup nor the mesh at first glance but in my opinion the geometry looks a bit odd in the sense that it has some “wavy” surface - the mesh itself with close to 90 illegal cells. I will go through each points again and invite @yosukegb4 (for geometry advice), @vgon_alves as well as @jhorv_th for additional hints and tips.

Best,

Jousef


#3

I think it is a geometry problem, because I fixed it and for now simulation runs


#4

Great! That’s the only thing that really bothered me.

Can you share the new project with me to see the new model? Cannot access the link in your first post - I assume you set it back to private. Also let us know if you used a special export option from your CAD software or what you did to fix this issue. Might help other people in the future.

Cheers,

Jousef


#5

https://www.simscale.com/workbench/?pid=1237587855504468150#tab_0-0

Something is still not OK. When things will get good I will post the solution


#6

Hi @sengineering!

I believe that the non-smoothness of the geometry causes problems. Maybe use the same export options as used for “Formula_4” for instance. Let me know if that fixed the issue.

Cheers,

Jousef


#7

Hi everyone,

Please, what is the geometry that you are referring to? Is it still “Formula_8”? I found many issues about that.

Cheers,

Vinícius


#8

Yes it is still Formula_8


#9

Hi everyone,

At least the sidepod geometry seems bad for meshing.

Regards,
Yosuke


#10

The problems I encountered are exactly what @yosukegb4 mentioned.

Cheers,

Vinícius


#11

Hi @sengineering

I noticed that, following the right hand rule, your angular velocity for the wheels is opposite to that of the movement of the car.

You might also want to check the sidepods, as the other members have pointed out.

Cheers,
Pablo.


#12

It is strange that I haven’t changed sidepods and the problem occurred.

So my wheels are spinning in wrong direction?

cheers


#13

Hi @sengineering!

The angular velocity has to be positive in your case. According to the right hand thumb rule the forward velocity for the x-axis is already positive defined in your case so no need to define a minus.

Best,

Jousef


#14

Just to add to @jousefm’s comment:

image

Or this other figure:

Just change torque for angular velocity and you get the picture of how the wheels rotate.

In your case, you have to multiply either the axis or the angular velocity by -1.

Cheers,


#15

Ok, I have changed angular velocity and also build new sidepod (Formula_10), which hopefully is now ok. But something is still wrong and simulation does not start.


#16

Hi @sengineering!

Are you talking about the Formula_10 run or other runs as well?

Cheers,

Jousef


#17

Hi @sengineering ,

All parts of a CFD model car geometry should have some thickness.
It is necessary for sidepod panels and wings as well.

I usually set thickness around 5mm to 10mm at least in order to reduce mesh nodes in my models.
As examples for reference, I link my CFD car models below.
https://www.simscale.com/workbench/?pid=8042688191781154255#tab_0-0

Regards,
Yosuke