FSAE CFD meshing and simulation convergence issue


#1

I have been trying to finish the FSAE webinar but the simulation fails to converge even if i follow the tutorial step by step, and even the number of illegal faces shown in th mesh log is 767 illegal faces instead of the 41 as it is supposed to be according to the webinar.
project
https://www.simscale.com/projects/siddhartha225/fsae_2017-workshop-s2-full_car_aerodynamics_2/#


Step-by-Step Tutorial Session 3 - Yaw Angle Study (Part 2)
#2

Hi @siddhartha225!

I am having a look at that and will get back to you as soon as I have found the cause.

Cheers!

Jousef


#3

Hi @siddhartha225,

Let me check on my end and see if I can get the illegal cell count down.

Cheers.

Regards,
Barry


#4

Hi @Get_Barried & @siddhartha225!

For me even the standard case which should run easily threw an error in the early stage of the simulation. Will have to check that out more specifically.

Best,

Jousef


#5

Hi everyone,

Not having much progress on my side. Illegal cell count actually went up to over 1000. Still working on it but it may be quite tricky.

Cheers.

Regards,
Barry


#6

Which step by step guide is this for? Can some one post me a link?

I did a checkMesh -writeAllFields and its shows poor quality throughout the mesh, really bizarre.

Cheers,
Darren

edit: this one?


#7

Hi everyone,

I am also having the same problem as @siddhartha225.
Here is my project link:
https://www.simscale.com/workbench/?pid=4524937696477005777#tab_0-0

And I have followed the Tutorial quoted by @dlynch.

Earlier I had meshed the same geometry with less than 150 illegal cells but now, the same geometry when meshed with the same settings ends up with over 2000 illegal cells. Due to this, the simulation does not converge.
I think this may be due to some changes in the mesher made in the recent months.
I tried to reduce the illegal faces count by changing some settings but was not successful.

I would be grateful if my geometry could be meshed like earlier and I could run successful simulations again.

Thanks,
Varun


#8

Hi @varunkotian!

I am currently having a look at the issue and will get back to you guys as soon as possible!

Sorry for any inconveniences caused!

Jousef


#9

jousefm, have you ever found the answer? 2 days have passed and i’m really interested! thanks!


#10

We are still having a look at it @Rightes :slight_smile: I will inform you if we find out something!

Sorry again for the inconveniences!

Jousef


#11

Hi @Rightes,

The meshing is not working as intended so we’ll need a quite a bit more time to fix the issue. Apologies for delays! We’re working on it!

Cheers.

Regards,
Barry


#12

Hi all,

I’ve managed to reduce the illegal cell count down to 134 for Mesh 1 and 99 for mesh 2 in this copied over project. The settings are all default with the exception of the no of iterations for removal of bad cells where I’ve increased it to a higher amount with mesh 1 having a lower amount than mesh 2.

I’ve also went ahead to simulate the first mesh and it does work but the results seem to be diverging. Some adjustment in the relaxation factors or numerics will help in ensuring the simulation is stable (see under run 3). It will also need more iterations.

Hope this helps.

Cheers.

Regards,
Barry


#13

Thanks a lot for your help, The meshing and the simulation seems to be working fine now.
I just have another question,
Can we calculate the the co-ordinates of the COP of the body in post processing of sim scale?


#14

Hi,

The link shows that the project is removed. Could you share the link of the project again.

Thanks,
Varun


#15

Hi @varunkotian,

I have cleared the project in my project dashboard when I saw it was copied over once. I believe you have copied that over somewhere and you can obtain it from there.

Cheers.

Regards,
Barry