SimScale CAE Forum

Follower Pressure causes simulation failure


#1

As previously discussed I am trying to simulate the expansion of various designs of hollow hyperelastic structures (sort of like blowing up weirdly shaped balloons). As was pointed out to me earlier, I need to use the boundary condition ‘follower pressure’ rather than ‘pressure’ to keep the internal pressure acting normal to the inner surfaces during the large-scale deformation (200%+). However, I am unable to get simulations to work reliably using ‘follower pressure’; they usually either don’t start or run ‘forever’ with no convergence and no results. Unfortunately, while I understand the simulation techniques in principle, I don’t know enough about the specifics to figure out what’s going wrong and, more critically, how to resolve it, I tried a different solver, LDLT, accepting the defaults, and that got some results despite failing around 25% into the job…

Help needed, please…

Project Link


#2

Hi @irving and thanks for the detailed description of your problem.

@rszoeke & @ggiraldo , can one of you help out in this case? That would be more than great!

Cheers,

Jousef


#3

Hi @irving,
without looking at your project, as follower pressure is highly nonlinear on such large deformations, my first try would be to enable line search as this can significantly improve convergence (but only if there is no physical contact).
For the solver, almost always MUMPS is the best choice wrt speed and robustness. Finally mesh quality can also play an important role.
Tomorrow I can have a look at your project and maybe have some more suggestions.
Best,
Richard


#4

@rszoeke

Hi Richard,

I tried turning on ‘line search’ . The simulation took 16min against 2min, 1.067hours core time against 0.153 and aborted exactly the same at 24%, giving a near identical result. The only other difference is the error message was:

Newton convergence could not be reached. Possible options to prevent that behavior: Update the tangent matrix more often, increase the maximum number of iterations, use automatic timestepping or decrease the timestep.

rather than the more usual:

The solution matrix is not factorizable. This might be caused by an unconstrained rigid body motion or by overconstrained degrees of freedom due to multiple linear relations at at least one node.

So I tried a smaller timestep of 0.1s instead of 0.25s. No difference.

I’ve also tried a fine mesh but that just yielded a similar result.


#5

Hi all,

I’m still no nearer resolving this issue. @rszoeke and @jousefm, you were both looking at this for me at one time but I don’t think we came to any conclusions on the way forward. Any chance we could resume?

Best,
Irving


#6

Hi @irving,

Are you able to share you most recent project so others can take a look at it?

Thanks,
Christopher


#7

Hi @cjquijano

The link was in the original post, reproduced here: Project Link

Best,
Irving


#8

Hi @cjquijano, @rszoeke, @jousefm, @ggiraldo

Has anyone looked at this recently and can shed any more light on the subject? A colleague got a similar one working in another package but I have no idea how to translate that back to here and, apart from not having access to that package I’d really like to get the more complex simulations working so I can name-check SimScale in the paper I’m aiming to present next year.

Best,
Irving


#9

Hi @irving and excuse my delayed response!

I would like to take a look at your colleague’s paper to see his settings and then see if I can make the simulation work similarly. You can send it to jmurad@simscale.com.

Best,

Jousef


#10

Hi @irving,

I would be interested in seeing the results from the other package if possible. Probably max deflection and Max nonlinear strain over time. Currently I have the same issue as you. I can get results upto t=2.25 and then it falls apart. The stain at that point is about 120% which should be reasonable for your material. I want to look at how the mesh is deforming to see if that is an issue but I have limited time right now.

Christopher
christopher.quijano@gmail.com


#11

Hi @irving,

I have been trying to see if I can make the simulation work, mainly with numerical settings, but with no success. The simulation fails at around 2.3 seconds of simulation time.

Will report back when I get something meaningful to contribute.


#12

Hi @jousefm, @rszoeke, @ggiraldo & @cjquijano

Many thanks all for helping out.

Sadly I don’t currently have access to the actual model as my colleague is away at the moment. However it was based on the information here: Soft Robotics Toolkit and, in particular, the info in the section on modelling

Can SimScale be scripted in this way? I know OnShape can to produce the model, but can I script the import/mesh/simulate process?

Best,
Irving


#13

Well, still no joy, anyone? The student version of Abaqus only supports 1000 nodes so can’t even try it out. But Solidworks 2018SP04 (Student Engineering Kit) Plastics module fails at about the same point so you’re not alone!


#14

Hi @irving!

Let me tag the @PowerUsers_FEA again here and see if we can achieve something here. @rszoeke can maybe add his comments here as well.

Best,

Jousef