SimScale CAE Forum

First Simulation Taking Too Long To Run


#1

Hello

I am running my first simulation: https://www.simscale.com/workbench/?pid=163825936542651767&mi=run%3A2%2Csimulation%3A2&mt=SIMULATION_RUN

It is taking too long to Simulate. Could anyone advise on what settings to change to speed things up? It is a multiphase simulation from a model imported from Revit.


#2

Hey @bveasey,
your Mesh has 5.4M Cells, it takes time to caluclate. :slight_smile:

You use the Hex-dominat Algorithm with the fine option. Maybe you can use the Hex-dominat parametric algorithm to get a coarser mesh at non-important places.
or
What do you want to calculate, the pipesystem at the beginning or the outlet at the bottom?
It is possible to remove not necessary parts in your geometry ?

Best regards
Kai


#3

Hi Kai

Thank you for your response, it was very helpful.

I have split the simulation into two. The first is an Incompressible one on the manifold only. I want to make sure that the velocity in the main body is below 0.6m/s and that the 8 outlets have similar flows (about 115 L/min on each). Here is a link to my new Manifold Simulation: https://www.simscale.com/workbench/?pid=2983185648458008041&mi=run%3A1%2Csimulation%3A1&mt=SIMULATION_RUN

The second Simulation is a Multiphase one for the Trough. This is for an architectural water wall. I want the Simulation to tell me if there is an ‘even’ level of water passing over the weir along the weir’s length. I have started the Simulation and now waiting to see if it will complete… Here’s a link: https://www.simscale.com/workbench/?pid=1442608461382913669&mi=run%3A1%2Csimulation%3A1&mt=SIMULATION_RUN


#4

Hello bvasey,

That’s a nice first simulation, I have to say. Keep it up!

Now I don’t know much about architectural waterfalls, but it feels to me that it would be a single phase flow. In your second simulation, if there’s only water coming from the pipes, then there would be no air in the domain.

A couple of things about the setup. The boundary condition that you set to the outlet is causing the simulation to crash. You currently have a pressure inlet-outlet velocity BC for the outlet face. This BC will prevent any fluid from going out. You can change it to an ordinary pressure outlet.

If you really need this simulation to be multiphase, I believe you can use the local time step approach, which will help you achieve a “steady state” faster (saving you quite a lot of computational effort). If you decide to go for it, you can activate this option here:
image

Keep us informed :wink:

/Ric


#5

Hi

i am having a problem with both simulations. i have tried viewing the manifold results with Particle Traces - but they look terrible! Some traces are outside the body of the manifold and there doesn’t appear to be enough traces present in the manifold.

I have set the Trough outlet to ‘Pressure Outlet’ but it still crashes…I have kept it as ‘Multiphase’ since there is air present in the trough.


#6

Hey @bveasey,
im sorry, i cant open your first simulation in my firefox , my Ram-Memory fills up very quickly, and my firefox crashes :frowning: . It hadn’t behaved like this befor…
So i downloaded your simulationresults and open it in Paraview on my local maschine.
You can download it too: https://www.paraview.org/ its open-source.

I dont see this behavior in ParaView, i think your postprocessing result should look like this ?


I will look in your second simulation.

Best regards
Kai