Error without explanation (simulation)


#1

https://www.simscale.com/workbench/?pid=384832942760959074

I’m trying a new project on an FSAE car and got an undefined error which I cannot find out what it is about. The mesh worked out perfectly as well as the preparation job for the simulation. But the simulation did not give any results. I cannot understand what I did wrong. Did I miss a typo?

Could someone check please. :slight_smile:
Thanks in advance!


#2

Hi @estephan!

The mesh looks good at first glance but if you look into the mesh log you will see that you have over 2.5k illegal cells. The setup itself looks quite good though! @yosukegb4, any input from your side here?

Cheers and all the best!

Jousef


#3

yeah where do they come from? mainly at the Rearwing I suppose?
Can you track em down? then I try to create a new mesh.

Thanks!


#4

Hi @estephan,

I’ve done a quick check and shown below are the possible problematic areas.

The geometry itself has a minor problem but the bigger problem is in the second figure where your mesh is “double layering”. This happens when your geometry is not watertight and due to how complex your geometry is, the checker that states whether your geometry is watertight may have just stated that for one or two parts as seen in the blue circle where the double layering is not occurring. This can also happen when you set the bounding box to “cut” incorrectly. Typically the area where the FSAE car is cut in half is the point 0, 0, 0 so that when the bounding box is placed human error in setting the bounding box is removed. In your case it seems like the same position of the geometry is not present and rounding errors from possibly “eye balling” the size of the box in the Y direction which interfaces with the cut off side of the car or rounding errors from measurements in the CAD software may cause this issue.

I faced similar issues in my simulation here. Hopefully it will give you an idea of what I’m talking about.

You should look into both possible errors that I’ve mentioned and then go ahead and remesh it to reduce the no of illegal cells.

Cheers.

Regards,
Barry


#5

Yeah youre right! I just noticed that my exported monocoque is hollow! how did that happen?! Thank you very much I did not see that! :slight_smile:


#6

@Get_Barried @jousefm
thank you for helping me with my first simulation. I got it another time
https://www.simscale.com/workbench/?pid=5904509483737292496#tab_1-0
here’s the link…
this time it is my radiator porous zone for my car without a driver. the earlier run was the one with another car… the newest run this test car does not work. We wanted to know how much the radiator takes impact and the driver has for drag impact.
Could you help me? It’s the simulation noDriver and the Run noDriver

THANKS! :slight_smile:


#7

Hi @estephan,

Refer to the figures below.

The mesh “noDriver” has over 5000 illegal cells and that is the cause of your simulation problems. You need to fix the geometry and remove any intersections. Preferably, you also want to make the parts are a single piece rather than a combination of multiple pieces in order to reduce possible meshing problems and make assignment easier. For example the sidepod could be made into a single geometrical selection along with the main chassis.

Also note that your inflation layers are not appearing. After fixing the geometry problems you can refer to this document on how to generate those layers.

Cheers.

Regards,
Barry


#8

okay thank you I will try that :slight_smile: thanks for the effort. :slight_smile:

me and my team already tried it another time without the radiator which made the most intersections…

https://www.simscale.com/workbench/?pid=641165195054557861#tab_0-0

it did not really help… but maybe there are more illegal cells. I try to improve the geometry a little more. It’s a difficult problem but I’ll try my best.