SimScale CAE Forum

Error: The mesh quality check detected orphan nodes in the mesh

I am working on the project here, and am running into some issues. Some of the parts in my model have some sharp edges:

Here is a closeup of one of those corners:

There are no errors reported in the event log for this mesh, but when I go to run the simulation, it finishes without producing results and returns this error message:

My question is, is there anything I can do aside from further modifying the geometry to avoid this error? Is there some guideline that can be followed as far as the smallest allowable edge size goes?

Hi Tim!

Apart from optimizing the geometry I would try to refine the outer frame which I assume causes the node issue - maybe you try that and see if the message still pops up.



I have reduced the size of the mesh on those faces in contact with the sharp edges of the corner braces and have also increased the size of the narrow face as shown below.

However, the same result is being produced. Any further ideas?

Hey Tim!

Have to check that out by myself, getting back to you as soon as I know more.



Hi @tlewis,
the use of “quadrangular surface elementes” in your mesh seemed to have cause an orphan node to appear and this crashed in the end the result data conversion. I filed a bug report for this.

As a workaround you can disable the quadrangular surface elements for the mesh. I made a copy of your project and tested this here.

Btw. using quadrangular surface elements is of no particular use in your project (it actually only creates qudrangular surface elements not a hexahedral volume mesh - you end up with a volume mesh made of pyramids and tetrahedrals), but it will create a lot more nodes and unnecessary computational effort (650K nodes vs. 370K nodes).

I would only recommend the use of the quadrangular surface element setting in specific contact cases where you need as much regularity on the surface as possible or in case you have boundary layers defined.



@rszoeke Thanks! That’s good information to know. It works now. Thanks for the help!