Error: p_rgh file not found


#1

Hi

I am setting up an multiphase problem, but I’m always getting the error “p_rgh file not found” when I start the simulation. I have tried different boundary condition but nothing works. Does this have to do something with the boundary conditions?
These are my boundaries:

https://platform.simscale.com/?publiclink=65b26619-b6bd-43e4-a5d8-34f39346950a

Another question concerning the boundaries:
If I choose Velocity Inlet e.g. on one plane. It states only velocity and phase fraction but nothing about the pressure, can I set another boundary condition for the same plane for pressure then. Because when I use OpenFoam without the gui you have to define boundary conditions for p, u, and so on for all planes. So far I am always using Custom.

greetings from
Hendrik


#2

Hello Hendrik!

Lets start with:

I took a look at your simulation and found two issues.

First, you selected “Set gradient to zero” BC for phase fraction at both inlets.
This is not a big thing, since the surrounding of the inlets is constant (same phase). Still I strongly recommend to use a “Fixed value” BC with a dedicated phase.

Second thing is the specific BC you used in the “bottom” condition.
It appears that due to changes in OF, the “Constant contact angle” BC behaves in a strange way on the platform.
I got in touch with SimScale engineering team and they are overcoming the problem (soon all should be fine).

After I changed the phase fraction bottom BC to zero gradient, the simulation worked fine.

Regarding the second question:

The new standardized BC definitions on SimScale automatically take care of the fields that are not displayed.
For example, with “Velocity Inlet” BC, you will not find the setting for pressure, yet SimScale will automatically select and set it up for you. Same goes with the “Wall” BC and others.
The “Custom” BC gives you manual access to the fields and a bit more flexibility in choosing non-standard types for each of the fields. At the same time, you have full responsibility to select the matching ones. For example, if you set Custom Velocity to “Fixed value”, you can not leave other fields with “2D empty”. In addition, not all pressure, velocity and other field’s BCs come well hand in hand. Some combinations might brake the simulation.


At this moment I would recommend to use some other BC type for the bottom phase fraction and after the simulation goes well, move to more sophisticated models- eat the low hanging fruits first!

Best,
Pawel


#3

Hello,

the “p_rgh file not found” issue was a parallelization bug on our side and is fixed now. Thanks @hendrikbaeumle for noticing this!

For the other issue, I think @psosnowski addressed it quite thoroughly. We also have some documentation on how our standard BCs work:

SimScale Documentation - Boundary Conditions - Fluid Dynamics

Hope it helps :grinning: