SimScale CAE Forum

Error during simulation run - door assembly


I am trying to simulate a door assembly, but I received an error message
during runs in next simulations:

  • Nonlinear Door_assembly_with 3D bolts (Run1,3)
  • Nonlinear Door_assembly_with 3D bolts and wall (Run1)

For example:

An additional information there is in solver log.

Unfortunately, I am not familiar with the solver. Could somebody help me , please?

The project link is:


Hi @atanas_kuzev!

I could not find a mistake in the setup at first glance but it might also be something completely different, will keep digging. In the meantime my colleague @rszoeke might add his thoughts here as he knows more about solver logs of this type than I do.




Hi @atanas_kuzev,
the error log you posted above hints that the hard disk size was too small for the case you were running.

Looking at your case, it is pretty obvious that the case should not be too large to be run on an instance with a couple of hundred GB of hard disk space available.
I was checking it with a newer version of the solver which we will roll out soon (within the next weeks) and there the problem disappears - you might have run into a case with a particularly poor disk space handling, which was resolved in a later release.

Until the new version is rolled out to everyone, you could improve the situation by reducing the “number of parallel processes”, I saw you were for example 8 on a 16-core instance (which is the default setup and usually the fastest). Using 4 instead of 8 will not reduce your run time too drastically (since we will still use all the processors available, but then more with shared memory parallelism and less with MPI parallelization), but the disk utilization will be reduced significantly in your case.

My guess is that this odd behavior is caused by the remote force loads you are using. You might also want to switch to “undeformable” remote force which should also fix the issue.

Edit: I just restarted your last run with the new solver version and it finished successfully:

If you want I can manually activate the new version for you (everything should already work, but be aware that the testing is not finalized yet).



Hi @rszoeke,
Thank you for your support. I would be grateful if you activate the new version of the solver.


Hi @atanas_kuzev,
from now on all your runs will use the new solver version for your structural analysis runs.
Let me know if you see any issues or unexpected behavior.



Hi @rszoeke,

  1. I started two runs with the new solver.

The error message for the second run received at the final stage - “finishing up”.
The solver log:

  1. Could the legend scale be adjusted automatically when only one part is displayed?
    All parts:

    One part (The maximum stress is about 78 MPa) :


Hi @atanas_kuzev,
regarding the error, it looks like it is related to one of the result control plots you defined. We are investigating and should have a fix by Monday. As I said, the new version is not yet fully tested, so these kind of issues are still possible.

Regarding the scaling to only visible parts, I think this is not yet possible, as we only have 2 options for the scaling, “manual” and “All parts automatic range” - I guess we would need a third one “Visible parts automatic range”.
Maybe @bdaqui knows a work-around for the time being?



Hi @rszoeke,
It would be very nice to have the option “ Visible parts automatic range”.


@rszoeke There is an experimental version for such a feature. I will check how mature it is at this point and how soon it could potentially be brought to production.


Hi @atanas_kuzev,
We have added a fix for the error you encountered. I’ve managed to successfully complete your simulation run ‘Run 1 Augmented Lagrange new solver’. Could you try again and let us know if you encounter any errors?

Kind regards,


Hi @svanschie,
I started “Run 1 Augmented Lagrange new solver fix error”, but he couldn’t converge in t=0,4s - see solver log.



Hi @atanas_kuzev,
I see that the only difference between your simulation and my test is the initial time step. Could you try lowering the initial time step from 0.1 to 0.025 and try again?


Hi @svanschie,
The simulation (Run 2 Augmented Lagrange new solver fix error) with initial time step=0.025 also doesn’t converge, but this time in t=0.75s.

The issue exists for simulations with "Augmented Lagrange " contacts, but not for “Penalty method” (Run 1 Penalty method new solver fix error).


Hi again @atanas_kuzev,
Try changing the option ‘Convergence criteria’ (under Numerics) from Relative to Absolute. I copied your project and successfully finished a run after changing this:


Hi @svanschie,
I also finished successfully simulations (although with different a geometry and settings). Thanks for your support.