Disable Model Window + Delete Job


#1

Model Window:
I was recently working with some CFD problem with a lot of elements. This takes quite a bit of time to render in such cases in spite of my fabulous internet speed. I could alternatively suggest that a possible option to disable the object rendering on the GUI screen.

This could be especially useful for those using SimScale at lower internet speeds. I am not sure how much bandwidth it eats to render the image everytime a user changes things / moves etc.

Delete Job
This was quite a bit annoying. I submitted jobs & later tried to stop / delete them. The system becomes significantly irresponsive once I issue stop / delete option.

I issued a stop command & then went on to work on changes in the model (like add rotating zones etc). The system didn’t respond after repeatedly trying to add these. I had to log out for a few minutes. Once I logged back again, the job was deleted and also multiple of these zones were added (one for each time I tried to add :stuck_out_tongue:).

This happened several times. This is definitely something that should be considered and something added in the backend to prevent the system from freezing.

Of course, these are simple things but just could make life smoother!


System Requirements
#2

Hi @ajaybharish,

Thanks for the excellent feedback! With regards to the model window, one thing that we recommend to speed things up if you are in the simulation designer is to switch from surfaces with wireframe to surfaces

This job deletion problem sounds like a bug - I will forward it along to the development team so this process can work more smoothly for you in the future!

Best,
Anna


#3

@AnnaFless

Thanks for the sending the bug report to the development team.

With regard to the surfaces option. I tried that. But when you change to a different mesh / model, it automatically switches to “Surfaces with wireframe” option and starts rendering again.

I just made a video of my screenshot: http://goo.gl/oZERl4

You can see here that it is rendering and there is a countdown with “loading” being displayed. Until it is finished, it continues to render. When I change the model that I intend to view, it again goes back to “Surface with wireframe”. You can see in the video that it can take quite a while at times.


#4

@ajaybharish - Yes I see your point here, that is pretty frustrating when switching between models. I’ll pass this along and see if there’s any magic that can be worked to improve this :wink: