Csv export


#1

Hi guys,
I’m having trouble exporting a useable csv file.
The problem is that the file export uses commas for decimals aswell as seperators. This leads to decimals beeing in a seperate column. Did anyone experience similar problems and knows how to solve it?
Thanks in advance!


#2

Hi @tfelser!

Are you using a Mac? You can try using the vim editor and fix your file because Excel on Mac causes bad behaviour with commas.

Best,

Jousef


#3

Hi @jousefm!

Thanks for the quick response! No I’m using Windows. Is it possible to alter the exported csv? For example use semicolons as seperators or points as decimal sign…


#4

Hi @tfelser!

You can use whatever editor you like. In addition to that you are able to select the separator when uploading your CSV.

Edit: Btw sorry you are talking about the export from Simscale and not the export from your machine to upload it to the platform. You could use a script for that. @1318980 any other input from your side?

Best,

Jousef


#5

Hi @tfelser, @jousefm,

Where are you exporting from to get comma decimals? I just downloaded a CSV from a plot and it was comma separated and decimalised with a stop.

Cheers,
Darren


#6

Hi @1318980,
I’m exporting a csv of a forceplot from post processing.
Thanks for your help.

@jousefm i don’t seem to understand what you mean by using a script, there’s just a button to download the csv file.


#7

Hi @tfelser.

Was referring to a script to modify the downloaded file because doing it with vim or any other editor might be a tedious task also taking into account that the forceplot csv can be pretty big. The best would be to share the project/file so that we can have a look at it and see what you mean. Makes it easier for us. :slight_smile:

Best,

Jousef


#8

I downloaded one of my force plots and it was comma separated and decimal by stop. Are there any local changes due to some countries using commas for decimalisation @jousefm ?

Kind regards,
Darren


#10

@jousefm @1318980 I shared the project with you. I also thought about the local changes but how would i fix that?


#11

Hi @tfelser and sorry for the small delay. Could you share a screenshot of the problem which might be the easiest way to understand what you are struggling with.

Can you also explain what you mean by local changes?

Cheers!

Jousef


#12

So by local changes I mean that if the region you are in uses comma decimal mark instead of point mark is there a setting on users computer or SimScale that account for this? and therefore change the point to a comma? If you open the csv in a text editor is it still comma decimalised? if not this would indicate an issue with the usage of excel.

Kind regards,
Darren


#13

@1318980 It’s decimalised and seperated by comma. I wrote a script as a workaround but it’s kind of an ugly solution…
@jousefm Maybe you can check the export options for Germany…

If anyone wants the script, feel free to message me.

Cheers and thanks for your effort,
Timo