Conjugate Heat Transfer Selecting Domain Error


#1

Hello,
I have a problem regarding conjugate heat transfer simulation.I am trying to simulate a brake disc and i have meshed it using meltiregion mesh true option and it is succesful.
But when i try to use the mesh as a domain it shows an error saying that Multi Region Mesh is required.

https://www.simscale.com/workbench/?pid=5436445300879558607


#2

Hi @123ankitj,
If you are trying to simulate a CHT, you need to have an interaction between solid and fluid domain. I saw your setup and understood that you need to set only the heat transfer module. It is possible to do in Simulation Design> Simulations> Analysis Type> Heat Transfer . There will be possible to have the temperature distribution on the disk, for example but in this case you will need to change your mesh.

Let me know if this is your purpose with this project. Here are some links that may will help you:
1 - A good introdution about Heat Transfer;

2 - Tutorial about Thermal Analysis of a Car Brake System;

3 - A similar case here.

If I misunderstood you, please sorry about me and explanate more about this case for I try to help you.

Cheers,

VinĂ­cius


#3

Hi @vgon_alves,
Thanks for your solution and lets try it out


#4

I have created two domains :fluid and solid.
But Still i am getting an error in meshing.
https://www.simscale.com/workbench/?pid=5436445300879558607#tab_0-0


#5

Hi @123ankitj,

What is the objective of your simulation? If you’re trying to find out how heat propagates throughout the entire brake disc and its dissipation you can do that with “Heat Transfer” under “Thermostructural”. If you refer to what @vgon_alves has kindly posted, pointer 3 will allow you do so with relative ease.

However, if you want to determine how heat propagates from the brake disc to another fluid, say a brake disc submerged in water, then “Conjugate Heat Transfer” is the mode you want but I doubt that would be the objective and if so it would be rather unusual considering the practical application of brakes.

With that being said, you new geometry titled “geom” is broken as you have intersections and hence that is why you are unable to mesh. You need to clean up the geometry properly before you can mesh it. The broken areas are clearly seen in the diagram below where the blue part is intersecting with the grey part.

Do determine what your objective is and then fix your geometry accordingly before attempting to mesh again.

Cheers.

Regards,
Barry


#6

Thanks @Get_Barried for the help


#7

Hi @Get_Barried
i have refined the geometry but now i am getting an different error about memory getting full.
https://www.simscale.com/workbench/?pid=5436445300879558607#tab_0-0
I have even tried reducing mesh refinements level but still getting same error


#8

Hi @123ankitj,

Which mesh are you referring to? Do note all your geometries are still broken and especially the “brak” geometry is overly complex. Only the first geometry is usable at this stage.

Memory errors are caused by not selecting 32 cores.

Cheers.

Regards,
Barry