SimScale CAE Forum

Compressible solver with AMI rotating zone


#1

I am attempting to run a transient compressible solver with an AMI rotating zone, and so far I have hit nothing but dead ends on getting the case to build. My original case is a ducted propeller, but I have been working with the centrifugal pump tutorial example to try to run through different settings more quickly (since the domain is smaller; see the link below).

To give a quick summary of what I’ve tried that works and doesn’t work (all cases are transient):

  • The simulation works with an incompressible solver and MRF

  • The simulation works with an incompressible solver and AMI

  • The simulation works with a compressible solver and no rotating zone

  • The simulation works with a compressible solver and MRF

  • The simulation does not work with a compressible solver and AMI

This leads me to believe it is a problem in the AMI formulation. This, along with the error log:

When running an incompressible solver, the output log is as follows:

From what I can garner, the floating point exception and the sigFpe message point towards a divide by zero error, which generally has to do with a zero pressure or turbulence values being set. I have initialized ambient pressure throughout the domain and tried a few different combinations of turbulence values for initial conditions. I also tried initializing velocity within the domain.

I am not sure where else the divide by zero error would be unless it is a problem with mesh quality in the region between the rotating zone and the stationary domain. However, being that the simulation builds correctly with an incompressible solver, I don’t think that is the case.

I have looked through different AMI problem posts on CFD-Online, but the problems there seem to be associated with 0 weights being assigned to the interface, however as shown above, my weights are quite close to 1. The closest thing I’ve come to finding is that during AMI rotation the weight factors end up being zero somewhere. However I don’t see how that would be the issue if it works with an incompressible solver.

Some other things I’ve tried are:

  • Changing from rotating motion to oscillating motion and applying a degree of revolution equal to several revolutions

  • Lowering the timestep

  • Allowing adjustable timestep

  • Adjusting initial and boundary conditions

  • Changing residual control values

  • Changing number of outer correctors

  • Changing density bounds

  • Changing time differentiation scheme

  • Changing wall functions to full resolution

  • Changing heat transfer to zero gradient instead of fixed value.

The project I’ve been working in can be found here:
https://www.simscale.com/projects/ltuite4/compressible_ami_test/

I’m at a loss on getting this case to build; I am stuck on it being an issue with using the compressible solver with AMI, but maybe I am overlooking something more trivial. Any help would be appreciated, thank you.


#2

Thanks a lot for the detailed description of your problem @ltuite4!

Let me investigate this and also forward this to my colleagues to see if something else than the AMI might be an issue here.

Best,

Jousef


#3

Update: The issue is under investigation and indeed there is something happening in the background causing the simulation to fail.

Once it has been fixed I will let you know! Thanks for bringing this up by the way :slight_smile:

All the best,

Jousef


#4

Hi @ltuite4,

Can you please try if your simulation works now? The issue has been fixed by the engineers!

Jousef