SimScale CAE Forum

Comma vs Point

Hi guys.

For a CFD problem i need to ramp the velocity.

Since the time steps are very small i would like to do it in excel for easy computation of my table.
However i run into the following.

I live in Europe and we or at least I use Commas as a decimal separator.
Unfortunately SimScale and the US use the point as a decimal separator.

I’d rather not switch my excel to points since al my other work is in commas.
What is a good workaround for this? I want to export to csv with off course points as the decimal separator.

Calculations can’t be done in excel on values with a point as decimal separator whilst commas is selected as the separator. Excel thinks these values are text.

Any ideas?

A feature in SimScale to switch to comma’s would be appreciated as well. Or maybe the whole world could just decide on what to use and stick with that…

Thanks!

Oke maybe i posted my question to soon. Here is the workaround i found maybe someone wil find it useful.

-Do all computations in excel using plain commas
-Export to CSV
-Open in texteditor
-Ctrl+F to find and replace all commas by points
-Save as CSV
-Done!

*Small note: When exporting to CSV don’t use the comma as the column separator use ; instead. This symbol can be replaced/substituted as well with the Ctrl+F command but only after you have replaced the decimal separator from commas to points.

Happy simulating!

2 Likes

@STR - brilliant, thanks for sharing! Wish I would have thought of that when I had the same problem a couple of weeks ago - instead I went through the hoops and changed all the setting on my computer to the US system :unamused:

Sharing is caring! At least now you can change it back to commas :wink:

1 Like