Combined.stl upload problem


#1

Hi everyone,

I have an issue when I’m trying to upload my own geometry on SimScale. After combining multiple .stl geometry files with the “cat” command in Linux, I try to upload the combined.stl on SimScale. Even though the upload is successful, only one of the previously individual .stl files is shown in the viewer. However, when I’m trying to open the combined.stl file with Meshlab in Linux, the whole model can be viewed.

I searched around the forum for a possible solution, but nothing has fixed my issue. The individual .stl files are exported as .stl format from Solidworks.

Thanks in advance and let me know if any extra info is needed.


#2

Hi @pmparitakis!

Can you share the file with us - Google Drive link or something similar works. The @PowerUsers_CFD and/or the staff will have a look at it asap and see how we can fix this issue so that you can continue to work on your project.

All the best!

Jousef


#3

Hi @pmparitakis I’m away from my laptop atm but have you tried opening in paraview ? If it’s something post generation it’ll tell you which lines are at fault, if it is a fault from software load in each individual file from the combination to see which one is at fault. Just an idea :slight_smile:

Kind regards,
Darren


#4

Hi @jousefm, @1318980! Thanks for the replies.

Here’s a link to the individual .stl files corresponding to the rear left & rear right tires of the model.

And here’s a link for the combined .stl of those two individual files.

Let me know what you think and thanks in advance :slight_smile:


#5

Hi @pmparitakis, if you search for ‘solid’ in the text file the lines between the solids read:

endsolidsolid P18_RRTire

Should be:

endsolid P18_RLTire
solid P18_RRTire

After altering this and loading in paraview I get no errors.

Hope this helps,
Darren


#6

Thanks @1318980, your suggestion solved my issue.

Do I have to do this every time I try to combine multiple .STL files together using the “cat” command? Is there anything else I can try in order to avoid correcting the merged .stl file in the end?

Thanks in advance!


#7

Hi @pmparitakis, normally that isn’t an issue but it must have been missing the new line. I have created a python script if you are comfortable using python? you could try it and see if it is better, if not just add in a newline in the script to correct it. If so ill link it to you.

Kind regards,
Darren


#8

Thanks @1318980 for the reply.

Does the python script correct the already merged file or you can do the merging of multiple .stl files without getting the error I got?

In any case, I’m comfortable with Python and I would be more than happy to test the python script, if you are willing to provide me with it.


#9

Hi @pmparitakis, no not correct just use it instead of. It takes each file, copies over the lines and where there is a ‘solid’ it changes the name to the file name. If this doesn’t fix your issue you can simply put ‘\n’ on the end of the ‘ensolid’ line (which is already in the script). I’m still away from my laptop, ill send you a link when I’m back.

Cheers,
Darren


#10

Thank you @1318980!

I look forward to testing the script.


#11

https://1drv.ms/u/s!AmmuZY9R6wFaiLZJI3ZKXC4UzKrJng

Here you go @pmparitakis let me know how it goes.


#12

Hi everyone!

Today, I got an upload error when I uploaded my ‘zipped’ combined STL file.
But I could successfully upload the same combined STL file without zipping.

It may not be related to this case.

Regards,
Yosuke Yamamoto


#13

Thank you @1318980!

I just tested your script and it did the job. I really appreciate the help!