CHT2.0 Temperature drop at the initial stage of simulation


I am experiencing something strange while working on CHT 2.0.
I set every temperatures I can think of to 18C, including initial global temp, air temp, natural ventilation air temp, far field temp, etc. So when I hit simulation, everything starts from 18C, but soon the temp drops to -25C.

Below image is at the beginning of the simulation.

And below is soon after.

You can see the temp of the probe point inside the model which plummets at the beginning.

Any guess what is going on…? This is frustrating because I used almost the same setting and slightly modified model geometry right before this simulation and I didn’t not experience this issue.


I believe the project is currently private, but from your description the issue could be related to:

  1. A setting could be wrong somewhere (boundary conditions, initial condition, power sources, etc.)
  2. Sometimes this also happens when radiation is enabled. Radiation and convection/conduction will be coupled when the simulation is fully converged, but until then there might be some ‘bumps’. If you don’t have any unphysical temperatures in the converged state, then it’s OK.

Alternatively, if you want to stop that behavior completely, you can go to Numerics > Field Limits and hard limit the temperature at 18 °C.

Edit: it might also be possible to stop this behavior by adjusting the relaxation factors for radiation-related parameters, but then the convergence rate might be affected.


Hi Ricardo,

Super helpful. Setting a hard field Limits + tuning the radiation relaxation factor helped.
This will work for the current simulation’s purpose, but very curious about what is causing this so that I can do more accurate simulations in the future. Even running simulations till conversion, some parts of the wall temp remain unreasonably low. I checked all the conditions but I couldn’t pinpoint any problems within my knowledge. I do suspect my 3d modeling file since this issue happened after I updated the geometry. Thanks!