SimScale CAE Forum

cellZone to simulate porousMedia


#1

Hi everyone,

I want to simulate an aerodynamic problem with a porous media model, and I am facing different problems in order to do it:

  1. Impossibility to upload more than one geometry in the same project: as I understood after contacting the support team, if I want to generate different regions inside my model (i.e. cellZones for porous regions) I can just start from multi-solid step file, although snappyHexMesh starts always from a triangulated surface. For this reason, I think it would be nice the possibility to import different STL, as it happens in snappyHexMesh. If I am wrong or there are other solutions, please give me a reply.

  2. Having not the chance to create a multi-body step file, I generated the mesh externally in OpenFOAM (creating cellZones to model porousMedia from STL). During the setup of the simulation I noticed that there is no porous model for incompressible solver. Is there a reason for that? Is the solver porousSimpleFoam not implemented in the platform?

  3. In order to simulate it, I switched to compressible solver, where it’s possible to model porous regions. But again I got stuck, because I cannot apply the model to the already generated cellZones. The only option is to create a cartesianBox in order to select a sub-domain. Unfortunately I cannot use this option, because my sub-domain is not a cartesian box. Again, is there a way to solve this issue?

Thank you very much.

Regards,
Daniele


#2

Hi Daniele (@DanieleObiso),

unfortunately all three of your points are right now not (entirely) supported on SimScale. Especially the missing porous media definition based on cell zones is probably the show stopper right now for the simulation setup you’d like to do. It’s being worked on right now.

For the multi solid file: Did you give Onshape (www.onshape.com) a try? It’s a solid modeler that runs in your browser which you can use to prepare files for SimScale.

Best,

David


#3

Hi David,

Thank you for your reply.
I am trying a workaround, simulating it with the compressible solver, even if I am still facing some convergence problems. But I think it should work. Would you recommend it?

I have right now a small problem with maximum runTime:

Actually, this parameter was set to 3000 s by default. I changed it, but I am always getting this message.
How can I solve it?

Thank you very much for your availablity.

Daniele


#4

Hi @DanieleObiso, I have checked your account status, and there are over 2k core hours left. @dheiny can you help him further?


#5

Hi @sijia,

thanks for the support.
After some time it actually worked again without any changing.

Daniele