SimScale CAE Forum

Basic electronic cooling doesn't work

Hello,
I’m trying to run a very simple simulation of electrical component cooling.
My issue is, every time I run the simulation I get this error: Maximum number of iterations exceeded.
I don’t understand why, I already double and triple checked the boundary and everything seems ok for me.
Can you please help me to solve this issue.

https://www.simscale.com/workbench/?pid=8796658065905729473&mi=run%3A3%2Csimulation%3A1&mt=SIMULATION_RUN

Regards.

Hey @rcorporandy,
i had a fast look at your mesh. I seems you have a box in a box, is it necesary ? My this cause the error.

Best regards
Kai

2 Likes

See the following explanation about the error

https://www.simscale.com/docs/content/support/eventLogErrors/maximumNumberOfIterationsExceeded.html

Also, having had a quick look at your simulation, your mesh is ridiculous coarse; it needs to be much much finer than that.

@Kai_himself well spotted! I thought that he removed the outer box as he used open inner region, but now I see he chose to keep existing part. It is almost certainly unnecessary.

1 Like

Thanks for your help,
I should have given you more information about the project, sorry about that.
I want to know the maximum temperature inside the cabinet (large box) generated by 4 electrical components (4 small boxes inside the cabinet).

I followed the link provided by @ roy_g but I’m still stuck.
I reduced the meshing size (it took me 4h) but same result.

1 Like

Hey @rcorporandy,

It’s a different problem that is occurring now. You’re using 4 cores to run this simulation and the machine is running out of memory (because your mesh size is too big for a 4 cores machine). Head over to simulation control and select an instance with more cores:

/Ric

It’s seems to work now.
Thanks a lot guys.

1 Like