Airflow simulation of a small pipe (Post-Processor Problem)


#1

Hi,

I am trying to run an airflow simulation inside a small pipe, but I am having some trouble with the post-processing step. I followed the fluid simulation (water, but I made sure to change the material to air since that is what I want), but when I got to the post-processor step, I am not getting the same view as the tutorial page, especially when I tried going into the “Solution fields.” My view is nowhere close to the image shown in the tutorial page, and there is no option to change time/frame within that solution fields tab, unless I go to the meshes tab, where I cannot even modify the time/frame value. I put my link below:

https://www.simscale.com/projects/gimin2248/long_pipe_airflow/

For some odd reason, before I open into the details of the project, it seems like the simulation run preview image is displaying properly, but I cannot now view the large view when I click on it. Is it possible that it is my computer’s problem, instead of SimScale? I am genuinely confused mainly at the post-processor stage because I followed along the tutorial steps and some of the internal features/tools within the “solution fields” tab is not found on my screen when I tried to look everywhere inside my project to find it.

Thank you in advance for your help!


#2

Hi @gimin2248!

Can you first tell us what tutorial you are referring to? Additionally you cannot expect the animation to run smoothly when it just jumps between 2 steps as you have prescribed a time interval of 1000 (ideally this number would be lower - for instance 50 or 20 but also means that it will write out every quantity at the step you prescribed thus longer simulation time). If you also could share screenshots that would help a lot because I do not get what you mean with “large view” :slight_smile:

Best,

Jousef


#3

Hi Jousef,

First of all, thank you for your reply!

The tutorial I am referring to is “Fluid Flow Simulation (CFD)” that is in the tutorial section of the SimScale website.
The “large view” I was referring to is the one shown in the image I’ve uploaded in this reply. When I clicked on the “simulation run” image in the project page, it just continues to be on the loading state but never finishes to show the simulation result.

Also, for the solutions field tab, as I mentioned in the start of this post, could you explain to me why mine looks quite different from the one shown in the tutorial page? Is the screenshots in the tutorial page older version of SimScale?

Regarding the timesteps and animation, I think it is okay to keep it as 1000 since I am primarily interested in seeing the final result of the pressure distribution inside the pipe after certain period of time (not the intermediate step results) and the velocity of air associated with it. If that is the case, wouldn’t keeping it at 1000 be still be okay?

Also, what I mean by the post-processor not working the way I wanted is that when I went inside the solution fields tab, it showed me this:


as opposed to the object being colored with blue, red, yellow, orange, etc to correctly illustrate the pressure levels, it is just one single color throughout the entire object (darkish blue/green?) which clearly seems like it is not something I want.

Thank you once again for your help!


#4

It looks like you loaded the ‘New’ postprocessor at some point and that is what you are seeing as default now in this project open session. Right click ‘Solution fields’ for option to use Old post processor again. New one is nice but not fun to use because you can’t save states yet or hide boundingBox faces and internalMesh on external meshes :disappointed_relieved:

There is just a different way of using color mapping in new post processor.

  1. Click on Results, then click on little world beside p parameter in the SCL list.
  2. Open the Results tree and then click on the parameter you just added to the Results tree.
  3. There you can unclick ‘Auto’ and set your Max and Min sliders to zero in on a data range you want to view.

I just ignore that fact and carry on…

Yes, since it is Static sim anyway (I think)

:upside_down_face: just passing it forward, it is pretty late now in Germany :smile:

If you like this please mark it as my FIRST solution :wink: OOPS, since I just found out that ‘marking as solution’ exists, I went back to mark a post as a solution in some Topics I have started and could not find a ‘Mark as Solution’ icon on a post anywhere, oh well, such is life … :slight_smile: