SimScale CAE Forum

2nd order mesh in selected regions

Was wondering if there is a way to opt for 2nd order elements in selected regions (face or volume).
This thought came up while doing a simulation with curved thin plate contacting square plates. Want to use 2nd order elements only for the curved thin plate in hopes of keeping number of slave nodes high ( on curved ) so that penetration can be checked. At the moment getting extremely high penetrations at contact.

https://www.simscale.com/workbench/?pid=5398130486588740399&mi=spec%3Af556685f-3ac2-4d69-b86e-a698f2ed46ac%2Cservice%3ASIMULATION%2Cstrategy%3A167

For reference could go through bonded core- AA8090 >> Run 46.
In the post-processor the curved plate has approx 1.5e-3m displacement where as it is supposed to be around 3e-3m ( which is the displacement of the rigid plate pushing down, also the master here) if contact compatibility is met.


Probe for displacement at contact point (approx) of curved plate (slave)


Probe for displacement at contact point (approx) of rigid plate.

Also wanted to know whether option of giving different mesh max element edge length is possible for different parts. Trying to keep the master mesh coarser than the slave. Currently while applying region refinement in the slave faces, the mesh of the master close to this slave face also gets refined. Is it possible to get the master mesh coarser than the slave mesh
Thanks

Hello!

It is not currently possible to create partial 2nd order meshes.

To fix the penetration, you can:

  • Refine the mesh in the area of contact.
  • Increase the penalty coefficient for the physical contact.
  • Decrease the time step to better capture the deformation process.
2 Likes

What about possibility of getting coarser master mesh. The local refinement given to the slave at curved faces are making even the master mesh fine in the vicinity.
The objective of having the master mesh coarser is to prevent penetration by missing it in the contact search.


https://mae.ufl.edu/nkim/egm6352/Chap5.pdf
As seen in the above master can penetrate into the slave. So wouldnt it be helpful to have the master mesh coarser. Any reason why the sizes are getting matched at contact points ?

1 Like

Hello again!

This is a feature of the meshing algorithm, which assumes that it is best to have compliant meshes at the interfaces. I know that sometimes this is not what we want, as in the case you describe.

Something you can do is to use the ‘Global radiation rate’ advanced mesh parameter:

Increasing this value will reduce the refinement propagation. I would suggest to try a value of 2 and maybe further increase it depending on results.

2 Likes

Shall try this out.
Thanks

1 Like