0% Simulation Progress After 2 Hours

Something odd is happening with one of my simulations. After 2 hours of run time, 4 core hours, there is still 0% progress, no solver log or any of the other outputs that I normally see when I run a simulation. It is almost as if it is stuck on an instruction or running extremely slow although the core-hours indicate it is consuming processing time. This has happened to me twice now but not all the time.

Also, when cancelling the simulation, it continues to run a very long time afterwards (40+ min) and there are still no outputs from the simulation. I would think there would be at least a solver log after 5.4 core-hours.

Any idea what might be causing this behavior?

Multiphase Jet - Run #2

Hi there! Are you using Mesh 9 for this?

Yes, Mesh 9.

It seems to be random. Run 3 is ok. Also, I created a new simulation Multiphase Jet II and run 1 stalled but run 2 is ok, again same mesh. Nothing is different between the two runs other than when I started them.

Try deactivating the ‘Potential flow initialization’ , and let me know how this goes :slight_smile:

The first try with flow initialization off seemed to run ok but again, this is a random event so that might of happened with it on as well. I will leave off in future runs and see if it reappears again.

Just curious though, does that function have some sort of iteration process that could get stuck in an infinite loop? That might very well explain the behavior.


No, potential flow initialization calculates the potential flow of the solution (velocity potential). I am not completely familiarized with the MULES multiphase approach (and if it is compatible with potential flow initialization in SimScale), but I think I recall reading in a forum of OpenFOAM about some issues regarding this type of initialization for the present approach (as you don’t have anymore a single fluid but a phase fraction of two). Anyway, I think all the algorithms you are using in your current problem are deterministic so I wouldn’t expect different results from one run to another. If you are using PISO, try reducing the Courant (CoMax) to 0.3. Also, you are aware you have the momentum predictor turned off, right?

1 Like

I am reluctant to lower the Courant valve as I am running out of processing time. 30,000 seconds is the limit and that only calculates about 0.4 seconds of real time. Reducing the Courant will mean even less real time. But so far, turning off flow initialization seems to be preventing the simulation from getting stuck.

I had reset the simulation settings which turned off the predictor. Thanks, I didn’t notice that.