Step-by-Step Tutorial: Homework of Session 1 - Level 1

Firstly, generate public link to your project:

Then on the “Drones Workshop” site, at the bottom right corner you have a direct link:

Finally in the pop-up window feel up what is needed:

Thank you @Maciek! :smile:

Hi, i have a problem with the boundary conditions. I tried it several times now, but it always results in an error:

Probably a wall function boundary condition has been assigned to the
bounding face of a MRF zone. Please check your boundary conditions and
make sure that no boundary conditions are defined on the bounding faces
of the MRF zones.

In my boundary definitions there are no surfaces selected twice and the overall count is 121. The same as the total surfaces count of the model.

When i click on “check simulation” it shows:

Warning: Some faces are missing a boundary condition assignment. If
you choose to proceed, a no-slip wall boundary will be assumed for those

Anyone had the same problems?

Der Christian,

it seems to me that you have assigned ab boundary condition to the bounding face of the rotating cell zone.

Make sure that you don’t assign any boundary condition to the yellow surface!



1 Like

beginners mistake. works now. Thanks!

I am running into a little problem. When I select the domain, a mandatory Materials selection pops up under Model. As far as I can see in you tutorial, no such subsection is presented in you menu.

it is missing in the second drone. I just added a new material with the same values as in the first drone. (Air)
It’s also described in the video.

It should create itself automatically; if not add it manually:

Hey Guys,

We just updated the platform with some new features (including the material library). That is the cool thing about SimScale: You will be automatically updated to the latest version without manual installation :smile:

I have also updated the tutorial.

Have fun!



1 Like


the reason for the “Materials” tree item not showing up in the tutorial that @Milad_Mafi put together is that it was released today. It basically introduces a material library for flow simulation, identically to the one used in solid mechanics and thermal simulation setups. For the flow simulation setup, this means you define the material settings not under “Model” anymore but you add a material, set its properties and assign it to the relevant domain. Once the workshop covers solid mechanics simulations, you’ll see that this workflow is the same for other setups.

@Milad_Mafi will update the step-by-step tutorial soon to make it consistent with the current UI!

Happy simulating!


:smile: - okay, he already did!

Hi everyone not posted in the community before so here goes.

My first simulation (Blade type 1 at 2100rad/s) came back fine results good and what was expected.

I then “Duplicated” that simulation sliced the drop down selected “edit” i renamed it and changed the angular velocity to 1575rad/s for the next sim. I created a run and sent it. I go back to the home screen and realise that I’ve renamed, edited and run a renamed version of my sim, and every time i click on the duplicate it returns me to my original simulation. I thought it might be a glitch because i duplicated it. so i deleted the duplicate and continued editing the original with different angular velocities.

I then went on to do the second blade type, Selected “New simulation” went through a few steps only to realise i was rewriting my original simulation from blade type 1. Really weird. Ive taken screen shots of before i click and after…

hope thats visible, it shows the edit drop down and then in the bar next to the sim once loaded you can see the name of the other simulation. I have also tried just clicking on the name and it still takes me to the wrong sim.

I apologise for any spelling/grammar mistakes I’m typing quite quickly.

Cheers in advance
Darren Lynch

Edit: New users can only post one image at a time… so you only get the first one and take my word for the other.

I would not go that way @1318980 aka. Darren.

Better keep one simulation and if you run lets say$$2100 \frac{rad}{s}$$ you have to change your value to lets say our $$1575 \frac{rad}{s}$$ and then re-run the SAME simulation and make sure you SAVE your velocity after typing in your new value in order to keep your falue fixed. Otherwise you will do another simulation with the same value (2100). Does this make sense? Way to much text from me for such a simple problem :smile:

If you have anything else what is on your mind just let me know.

Cheers mate!


I kinda misjudged the time the computing takes, the simulations most likely won’t finish before the deadline.
Do you mind if I return the assignment while the files are being processed?

It’s 4:00 pm CEST, right?



Hey Juhana,

just start all the runs and submit then your links! 4:00 pm CEST is right.




I’ve got another problem, SimScale won’t let me run the simulation for the Level 2 part.
I get a message every now and then saying that I’ve ran out of storage space.

On top of the workspace page, session one project size is 27,506 megabytes. Is it supposed to be that big or have I done something horribly wrong?



Hi @Juhana,

I am guessing that you could have missed something. Please see that you have setup the values in ‘Simulation Control’ as shown in image below ( Highlighted in blue ) . The image is from above Tutorial.

If so then, this means you should get only 1 save file ( as we save only at the last step). Therefore, each Run should not be more than about 400-500 megabytes. You can check this by clicking on the ‘run’ and looking under ‘Run Information’ in the center panel for ‘Result size’ (under the progress bar).

Then for 8 simulation runs the total size would be about 4GB or so.

If this was not so, then your ’ write interval ’ was smaller than as shown and that created many files. You will then have to delete the Runs that had larger sizes to free space.

Let me know if this helps.


1 Like

There we go. My write interval was wrong for half of my runs.




brief question here as this also happened to other users before: If your simulation setup says that you’ll write out more than 20 time steps, a warning pops up when creating the run that the result size might become very large. Did you write out fewer than 20 steps or did you oversee the warning? I’m wondering if we should make this warning more prominent or more “alerting” as it’s really a pity if a simulation runs well but the results get so large that it’s hard to handle them.



My write interval was set to 50 which is the default value for it (I think), other values were as instructed above.
I didn’t get any warnings. The file sizes ended up being somewhere between 3 and 4 gigs each.

I ran multiple simulations at the same time so my storage space exploded once they all finished.