SimScale CAE Forum

Workshop 2 Session 1 Homework: Optimization of a wing - Part I Meshing


#11

Hello @hfoester,

This is just a warning during the snappyHexMesh generation. Your mesh will be generated in spite of this warning, so please continue with creating the mesh and let us know if you encounter an error which hinders from getting a successful mesh. Meanwhile we’ll look into this issue to avoid such warning which might be misleading.

Sam


#12

Hi, I have a problem with the meshing with the wing with winglet. It does not let me select the faces sets, in other words, I select the wing then save and then it disappears like I have not selected it. So I have a problem with the refinement. How can I do? “A mesh refinement without topological entities was found. This refinement will be ignored. Please check the mesh refinements.”


#13

Hi, I have the same problem.


#14

Hi @sjesu_rajendra ,
I receive an error message and the status in the solver log is also “Error”. This means the mesh generation has not finished, even though the software “try to proceed anyway”.


#15

Hello @Dieginho @sebastian_milu,

Do you still encounter the issue? I just checked with a couple of projects, and I don’t encounter this problem.
Could you please check again and tell me? If issues still persists kindly send me from which OS and browser you are trying to use SimScale. I can check and get back to you.

Sam


#16

Hi sjesu_rajendra,
I tried to run the mesh operation again and it worked just fine. Thank you.


#17

I’m Still having the same problem, but just with the wing with winglet. In addition, I cannot finish the simulation, it says “Maximum execution time exceeded.”.


#18

@Dieginho Thanks for the reply. With regard to the simulation run - increase the Maximum runtime setting under Simulation control. I believe the values suggested in the tutorial should be sufficient for the run.

@Dieginho and @hfoester With regard to the mesh - there is some issue with the mesher and our Product Engineers are looking into it now. I will let you know when the issue is resolved. Please try mesh generation after that.

Regards,
Sam


#19

@sjesu_rajendra I have restarted the mesh generation and now (after 3 attempts) it was finished successfully. Thank you


#20

@hfoester, Exactly the issue! Getting a successful mesh is non-deterministic, though it is the same settings. We are looking into it.


#21

Hello @Dieginho and any other participants who have the mesh issue,

I just got some information from our Product Engineer. It seems to be a bug between OpenFOAM and one of the 3rd party libraries, which happens during parallel computing. The issue is still not solved since the reason is non-deterministic at the moment. But we have a workaround for now - if it is necessary to run the mesh at 32 cores please tweak the settings a little bit (say change the bounding box dimension by a very small value or the number of cells along any direction by a very small number, say 1) and re-run the case.

A better solution would be to run it in reduced cores, say 16. This should help for the time being. Meanwhile we are working on it to eliminate this problem completely.

Sam


#23

The problem is in the Topological Entity Sets, that is empty so I can’t select faces sets in the mesh refinement. I do not really know how to do it. I already completed the simulation in the case of the normal wing. I need to solve it in order to submit the homework before Thursday midday.


#24

Hi @Dieginho,

It looks like you did a split operation on the geometry - which will delete all the pre-set topological entity sets (when you are doing mesh refinements, you use topological entity sets associated with the geometry)


#26

I just did split for the winglet wing, the normal wing already had split. That’s why I did it.


#27

@Dieginho, I see. You can re-add these sets manually

To do this:

  1. select the correct faces (components) for the set
  2. click on create set in the top menu bar
  3. add a name for the set and click create

Here is the list for each set

  • edges-wing (Component3, Component9)
  • edges-winglet (Component10)
  • Wing (Component1, Component2, Component4, Component5, Component6, Component7, Component8, Component12, Component14, Component25)
  • Winglet (Component11, Component13, Component15, Component16, Component19, Component20, Component21, Component22, Component23, Component27)
  • winglet-tip (Component24)

#28

Hi guys,

I got this issue in the second mesh:

Should I start again or redo this mesh? Just in case, please, find attached my project link:

https://www.simscale.com/workbench?publiclink=0f24a443-66f8-47d8-b613-57770ca4e276

Thanks for your time.
Cheers
Alex


#29

Hey @Alexor,

It’s the same issue as above. Please tweak the settings or use lesser cores to get a successful mesh.

Sam


#30

Hello Everyone,

Important: Regarding Meshing Error

To avoid Meshing errors due to a Bug in OpenFOAM Library, Please use ‘16 compute cores’ for the meshing operation.

The above tutorial has also been updated in this regard.

Best, Ali.


'Optimization of a wing - Aerospace Workshop II homework' simulation project by AbdulWahab
'Optimization of a wing - Aerospace Workshop II homework' simulation project by Amritpalsingh
'Optimization of a wing - Aerospace Workshop II homework' simulation project by bogsuatean
#31

Still having the problem. I used (what I assume was) the updated tutorial, so I tried the 16-core option first. I got the error 3 times in a row, so I tried some other methods (change to 32 cores, even tried 8 cores, change cell count from 30 to 31, bound size, etc) and I am still having problems, so can’t do the second wing run. I double-checked all the settings/values, couldn’t find anything wrong there…maybe send this to the engineers?

Problem only occurred with the winglet mesh. Chrome 53, Windows 7 64-bit.

Could it be a problem where the mesh for the winglet and the main wing meet perhaps? Could be that the join, while technically seamless between the 2 objects, might cause the problem where a random cell vert lands on the seam, especially with the high tesselation.


#32

Hi @brendan_a_b,

This is not an issue with the model or SimScale platform. We run CFD simulations based on OpenFOAM code, and as mentioned above this is a bug between OpenFOAM and one of its 3rd party libraries.

Please make your submission with only the first simulation results as of now. We would be taking it into consideration as well - we value your efforts in doing this!

Sam