SimScale CAE Forum

WebGL issue


#1

Thank you for contacting SimScale Support.
If the WebGL is not receiving the data from our server, the reason is most likely that the WebGL is either disabled or had crashed. Please try deleting the local cached files and restart your browser. If you still have the same issues, please reset the WebGL by following these steps:


Chrome:

First, enable hardware acceleration:

  • Go to “chrome://settings”
  • Click the + Show advanced settings button
  • In the System section, ensure the Use hardware acceleration when available checkbox is checked (you’ll need to relaunch Chrome for any changes to take effect).

Then enable WebGL:

  • Go to “chrome://flags”
  • Ensure that Disable WebGL is not activated (you’ll need to relaunch Chrome for any changes to take effect).

Then inspect the status of WebGL:

  • Go to “chrome://gpu”
  • Inspect the WebGL item in the Graphics Feature Status list. The status will be one of the following:
  • Hardware accelerated — WebGL is enabled and hardware-accelerated (running on the graphics card).
  • Software only, hardware acceleration unavailable — WebGL is enabled, but running in software. See here for more info: “For software rendering of WebGL, Chrome uses SwiftShader, a software GL rasterizer.”
  • Unavailable — WebGL is not available in hardware or software.

If the status is not “Hardware accelerated”, then the Problems Detected list (below the the Graphics Feature Status list) may explain why hardware acceleration is unavailable.

If your graphics card/drivers are blacklisted, you can override the blacklist. Warning: this is not recommended! (see blacklists note below). To override the blacklist:

  • Go to “chrome://flags”
  • Activate the Override software rendering list setting (you’ll need to relaunch Chrome for any changes to take effect)

For more information, see: Chrome Help: WebGL and 3D graphics.


If you’ve tried all this and it still doesn’t work, you’re extremely unlucky! :disappointed:
There are some other things to try for you:

  • Try it in incognito mode. If that works, please try disabling extensions temporarily and enable them one by one to check which extension is causing the problem.
  • If you’re using an older version of Chrome (version 55 or 56) there is the possibility that under certain settings WebGL is still not working. Try upgrading to the newest version of Chrome (version 57).
  • The last straw to grab for running WebGL would be Chrome Canary, which is the developer version of Chrome. It can be installed alongside Chrome 57. This future version might not have the problem anymore.

Firefox:

First, enable WebGL:

  • Go to “about:config”
  • Search for “webgl.disabled”
  • Ensure that its value is “false” (any changes take effect immediately without relaunching Firefox)

Then inspect the status of WebGL:

  • Go to “about:support”
  • Inspect the WebGL Renderer row in the Graphics table:
  • If the status contains a graphics card manufacturer, model and driver (eg: “NVIDIA Corporation – NVIDIA GeForce GT 650M OpenGL Engine”), then WebGL is enabled.
  • If the status is something like “Blocked for your graphics card because of unresolved driver issues” or “Blocked for your graphics driver version”, then your graphics card/driver is blacklisted.

If your graphics card/drivers are blacklisted, you can override the blacklist. Warning: this is not recommended! (see blacklists note below). To override the blacklist:

  • Go to “about:config”
  • Search for “webgl.force-enabled”
  • Set it to “true”

(Like Chrome, Firefox has a Use hardware acceleration when available checkbox, in Preferences > Advanced > General > Browsing. However, unlike Chrome, Firefox does not require this checkbox to be checked for WebGL to work.)


Safari:

  • Go to Safari’s Preferences
  • Select the Advanced tab
  • Ensure that the Show Develop menu in menu bar checkbox is checked
  • In Safari’s Develop menu, ensure that Enable WebGL is checked

We believe that this should solve your problem. If you have any other problems, please let us know!


Freezing Dashboard
#3

Hi Sai (@sgrandhi)!

Can you try clearing the cache?

What browser are you using?

Best,

Jousef


#4

Yes the simulator worked. I think it was the cache.

Thanks for your help.