Velocity inlet discribe by a CSV file


#1

Hey Forum,
i got a problem with my Velocity inlet, the inflow should be discribe by a CSV file.
In my simulation, the time step length is 0.01 sec from 0 till 30 sec. I build a CSV file with two columns, the first is the time and the second is the velocity in y direction. It starts with a row 0 to 30 dividet by steps from 0,01 sec and the equivalent velocity. After 1 minute i got an error, and no solver log.

It is about Run 3 30sec, here is the link.

Thank you for your help.

Greetz Kai


#2

Hi @Kai_himself!

Are you using a Mac to create the CSV file? Had some problems in the past because of that - feel free to share a Google Drive link of the file here if needed. The @PowerUsers_CFD and I will still have a look at the project to see if anything is wrong with the setup itself.

Best,

Jousef


#3

Hey @jousefm,
Thank you for your help. No i use MS Excel on Windows 7.
Good night,
Kai


#4

Without the CSV itself, I couldn’t tell you exactly the issue, but ensure you uses ‘comma separated Values (.CSV)’ not ‘CSV UTF-8(Comma delimited) (.CSV)’ format. also try removing the column headers and just upload values.

Kind regards,
Darren


#5

Hey @1318980,
i remove the headers, but it wont work. Here is the Google Drive link.

Greetz Kai


#6

Hi @Kai_himself, sorry I should have seen the issue the first time I looked, you need to provide all components of velocity. so you need 4 columns time, x-vel, y-vel and z-vel. where a value is then column 2 (but reads 2,3 and 4).

Hope that helps,
Darren


#7

Hey @1318980,
no problem, i have to sorry, it is in your documentation. Sorry.

I fixed the csv file, here ist the link again. The column for the time is 1, and for the value is 3. But it will not work. The simulation broke up at 1 min.

Greetz Kai


#8

Hi @Kai_himself,

looks like that is semicolon delimited instead of comma delimited?

Best,
Darren


#9

Hey @1318980,
i have shorten the simulation duration to 0.1 sec, its easier with the csv file ;).

I creat three csv Files

File A with a header and semilcolon as the delimiter
File B without a header and semicolon as the delimiter
File C without a header and comma as the delimiter

all three sim. A, B and C are not running well.

Furthermore at Run C2 i disable Adjustable Timesteps, but it dosen’t run too. :frowning:

Greetz Kai


#10

Hi @Kai_himself, the value column should be 2, not 3, and time is as it is 1. I did this on a copy and ran to 60% and failed for stability reasons (overly high Courant number).

Good luck,
Darren


#11

@1318980,
it was my mistake, i think i have to point the column with the velocity in the y direction. Now i understand your post, sorry again.
Now it works for me too.

Kai