Unsuccessful server response code of: 500


#1

Hello everyone,
I´m having a problem and tried to upload a step file many times, but always get an error “Unsuccessful server response code of: 500. I have a sketchup file, imported into rhino, and from rhino to step format.
I saw the same problem on forum, but I don’t know how fast i will get the help. I have an urgent assignment to simulate a pedestrian wind comfort in a city. Maybe someone can do it for me for a small fee.
Link to project https://www.simscale.com/projects/jdugintseva/novorossiysk_1/


#2

Hello, I´m having the same problem and tried to upload step file many times, but always get an error “Unsuccessful server response code of: 500. I have a sketchup file, imported in rhino, and from rhino to step format.


Can't upload Geometry
#3

Hi @jdugintseva!

Could you share a Google Drive link (or something similar) with the CAD model please? We will have a look at this! You can also upload a *.3dm Rhino part, just for your interest.

All the best!

Jousef


#4

Thank you for responding!
Did I understand right - CAD model is the same as sketchup?
https://drive.google.com/open?id=19h50CJn-sXWIPKUptcfEeXO4P0Vws-52
https://drive.google.com/open?id=1_Y0_Q_cXcF_nulTsjbUEgZwO7qgurWB-


#5

Hi @jdugintseva and sorry for the delayed reponse!

Unfortunately the upload on Onshape (!) took super long and the model is really lagging when I am trying to have a look at it. Do you have the possibility to export it as an STL file? @yosukegb4, you are an expert in Rhino. Can you give @jdugintseva some advices or tips on how to achieve a good export? That would be great! :slight_smile:

All the best!

Jousef


#6

Thank you very much for helping, maybe I should zoom out the model? Now It’s in a natural scale. But in this case I don’t know if the simulation will be realistic with real wind load parameters


#7

Exported file as an STL
https://drive.google.com/open?id=1uoc6ezzBAH2lttbM-jB99DojK4gHYyXr


#8

That looks quite good so far @jdugintseva, good job!

The question that I have is why there are some smaller models far away from your area of interest (see picture below):


On top of that make sure to split the surfaces of the geometry using the STL operation in the Mesh tab in order to establish a properly meshed topology.

Cheers!

Jousef


#9

Honestly, I don’t what is this, because this smaller models don’t figure in my model))
In the end, you managed to download the model to the server? How can I do the same thing?
Sorry for my noobing, I can’t understand what do you mean offering to establish a properly meshed topology and where I can do it using the STL operation?


#10

That’s weird @jdugintseva - just remove them in Rhino and re-import the CAD onto the platform :slight_smile: I just downloaded your model and created a new project, is that what you meant?

For the splitting operation please see the picture below:

Cheers!

Jousef


#11

Yes, that’s what I meant) after I wrote that I can’t understand, I just tried to upload the STL model and everything became clear) enormous thanks for helping!!


#12

I’m sorry, but I have a new problem :sweat_smile: surfaces don’t want to be splited! Every time error happens, Is It necessary to make this operation?


#13

Hi @jdugintseva!

Trying it too. If the error keeps coming the best would then be to do the splitting in Rhino and it would be good to group the building in order to have a manageable amount of faces. Maybe @yosukegb4 can give you some hints for efficient splitting inside Rhino.

Cheers!

Jousef


#14

Hi @jdugintseva ,

I checked your STL file ‘Novorossiysk.stl’ in MeshLab and found some wrong meshes.

  • Some Isolated Meshes
  • Non Manifold Edges
  • Self Intersecting Faces

I think it’s better to combine the original shape data into one solid model and then export it to a STL file.
But I’m not sure that SketchUp has enough functions for data editing like that, sorry.

Best,
Yosuke Yamamoto


#15

Hi!
Thank you for advices. It’s so pity and strange, that one simple model in sketchup made so many problems. Rhino doesn’t want to import my skp file and I had to export skp to 3ds, than import 3ds in rhino. Maybe that’s why STL file got wrong meshes, edges and faces? But I don’t know, how to make STL file from sketchup, It cannot do this. I did meshes to NURB in rhino, than merge all faces, but it went wrong.


#16

Hi @jdugintseva !

Your Rhinoceros model seems just meshes via 3ds format. They are not solid/surface data on Rhinoceros. Just the same as STL data.

Rhinoceros and MeshLab have some mesh operating functions, but I’m not sure whether they will work as expected.

Anyway, it is the same as the last post, I recommend you to combine the model as one solid data in any CAD first and to export it as STL.

Best,
Yosuke


#17

Thanks a lot! I will try to do your recommends