SimScale CAE Forum

Trouble refining mesh to remove bad elements

Hello,

I’ve ran into trouble in some of my CFD runs as the flow begins to diverge. I have recognised the face that is causing the divergence, and it is because of the aspect ratio of the mesh elements there, however I am unsure on how to make the mesh better. I have tried creating more fine meshes, less fine meshes and adding region refinements to the point in question but it doesn’t seem to better the aspect ratio.

Any help on this would be greatly appreciated!

https://www.simscale.com/workbench/?pid=8749582573198093307&mi=spec%3A46ccd9e5-9bd8-4a22-9a2f-e2d2532aa350%2Cservice%3ASIMULATION%2Cstrategy%3A9

Hi there, thank you for using the forum!

I took a look and have some comments regarding your project:

  1. You can use this tutorial as reference when it comes to meshing: Aerodynamic Flow Behavior Around a Vehicle Tutorial | SimScale
  2. Try to decrease the global fineness to 5 or 6
  3. Then focus on adding refinements on the critical areas. Check the tutorial I sent you above, and set region, as well as local element size refinements in your own one as well. Especially when it comes to “problematic” surfaces.
  4. Always make sure to check the mesh quality: Mesh Quality | Mesh Visualization Tips | SimScale Documentation

Let me know if this works well :slight_smile:

Best regards,
Fillia

Ahh okay thank you, I’ll look through that and give that a go!

1 Like

Hi, I made the refinements as suggested, but it still did not change the mesh values. It actually increased the edge, volume and aspect ratios?

I suggest you follow the instructions of the tutorial, that include:

  • Two region refinements for two cartesian boxes of different sizing.
  • A local element size applied on the whole vehicle

Of course you don’t have to use the exact same values for the length inputs. For example, the local element size you are using has a really small value that results in a very fine mesh only on these surfaces.

I followed the tutorial and it seems like the sizing of the mesh elements are ok, but the mesh values in the log are still too high?

Hi,

When it comes to divergence due to poor mesh quality, the two main workflows are trying to improve the mesh settings and/or cleaning up the CAD model around the problematic regions.

This article that I wrote shows the usual troubleshooting steps (which are essentially the same for every simulation). By following the steps in the article, you will notice that the simulation is diverging around this region:

Having a look up-close, you will notice a very small gap and a lot of thin faces:

Checking around the opening of the gap:

Judging by the model, and these small faces cleaning up the model is definitely a good idea. Thin faces and gaps are not really desired, in terms of mesh quality and simulation stability.

So if you are willing to clean up the model (which is usually my recommendation), that would definitely help.

Alternatively if you are not willing to clean the model, here are some things that are worth a try:

  • Increase the value of the small feature suppression, to try and ignore the small details. The value that is defined for the small feature suppression needs to be larger than the details, so they are ignored.

  • Using a hex-dominant meshing algorithm. The hex-dominant tool has basically an “built-in” filtering mechanism for small details, related to the cell size. If the topology is much more detailed than the mesh size, it will be ignored by the hex meshing tools.

In any case, using a clean CAD model always helps!

Good luck.

1 Like

Amazing thank you so much, found a few bits in the CAD that were messing it up and re-ran the simulation and it run without a problem!!

2 Likes