SimScale CAE Forum

Step-by-Step Tutorial: Homework of Session 3


#49

Everytime my mesh crashes when I want to make a layer addition…have someone a idea?


#50

Hi @Milad_Mafi ,

I am still having trouble while simulating the rear wing after importing from Caeses. Every time it shows maximum execution time exceeded. What should I do? Here’s the project link and the screenshot

https://www.simscale.com/workbench?publiclink=3195e0bf-5a71-45c2-b017-2e24cb739428


#51

Here there are few pictures of my simulations







#52

I tried to meshing two different geometries but i received every time the same message saying “the machine ran out of memory” and the meshing process crashed, so I can’t proceed. I used the same parameters setted for the original geometry assigned that worked fine fot it.

edit: changing refinement levels from 8 to 9 in edge refinement fixed the problem!


#53

Hi @cnapole, the same saved empty file error occurred to me when i saved a file with the same name of a previous saved file, rename the file when saving fixed the problem for me.


#54

Hi @debroy84863568, I have just checked your account status, and the rest computing quota should be enough for running workshop assignments. Here is a forum post about the message of exceeding computational quota. Hope this helps!


#55

Until now i tested all :wink:
the original caeses model (nothing changed) causes a an error in meshing… what can i do? have someone a working model for me? ^^


#56

So, I have a major problem: I cannot even get into the Caeses program!
I have downloaded it, registered and gotten the message that I will receive a verification-email. BUT I haven’t. I have tried with 3 different emails over the past 5 days, and it registers my email but I never get any verification email and thus I cannot even enter the program to do the homework.

Furthermore I cannot change the email for the login, so I cannot even borrow someone else’s.
What do I do?


#57

Hi,
Hi,

Very nice work!

I have changed the form since it was confusing.

Please submit total drag and total lift for 40m/s, 60m/s and 80m/s.

Cheers,

Milad


#58

Dear Nadia,

That sounds really weird. Did you already check your spam folder?

Cheers,

Milad


#59

Hi,

meshing of the initial mode worked for me. Are you sure that you used the latex model (we changed it several days ago).

Cheers,

Milad


#60

Hi @sijia, thanks for help. And yes, that forum post helped me all. I now got to know what’s going wrong with my simulation.


#61

Yes of course I checked the spam folder. That’s why I even tried different emails as well to see if something went wrong the first time. But I simply don’t receive any email.


#62

@Milad_Mafi Hello there! I tried meshing adhering to the HW2 procedure, also taking account of changes regarding the geometry primitives placement. It was taking abnormally long amounts of time and the process was being killed, and also observed an abnormal amount of cells (almost more than 60 million). Your help regarding this would be most grateful.


#63

Thanks for checking. I looked at it again and I have no clue how to include it. The Base Mesh Box is not even showing on mine, even though I clicked “Show”, and I also increased the box to absurdly huge numbers just to see if something would come up, but all I see is the frontwing geometry. I also used Chrome and Firefox and its the same issue. Does anyone mind posting dimensions used for their mesh box? I’d hate for the submission deadline to pass because of something I couldn’t see.

https://www.simscale.com/workbench?publiclink=177be6ac-5ba9-4dcf-9790-55707385d12e


#64

Hi Milad,

I can’t import the modified geometry to Simscale. I got error 500. What does that means?

Thanks,


#65

I’m having an issue with my meshing - the log is pretty inaccurate :frowning: What to do?
Merging all faces of a cell

  • which are on the same patch
  • which make an angle < 180 degrees
    (cos:-1)
  • as long as the resulting face doesn’t become concave by more than 90 degrees
    (0=straight, 180=fully concave)
    [27]
    [27]
    [27] --> FOAM FATAL ERROR:
    [27] Multiple outside loops:0()
    [27]
    [27] From function combineFaces::getOutsideFace(const indirectPrimitivePatch&)
    [27] in file polyTopoChange/polyTopoChange/combineFaces.C at line 423.
    [27]
    FOAM parallel run aborting
    [27]
    [27] #0 Foam::error::printStack(Foam::Ostream&) at ??:?
    [27] #1 Foam::error::abort() at ??:?
    [27] #2 Foam::combineFaces::getOutsideFace(Foam::PrimitivePatch<Foam::face, Foam::IndirectList, Foam::Field<Foam::Vector > const&, Foam::Vector > const&) at ??:?
    [27] #3 Foam::combineFaces::validFace(double, Foam::PrimitivePatch<Foam::face, Foam::IndirectList, Foam::Field<Foam::Vector > const&, Foam::Vector > const&) at ??:?
    [27] #4 Foam::combineFaces::getMergeSets(double, double, Foam::HashSet<int, Foam::Hash > const&) const at ??:?
    [27] #5 Foam::meshRefinement::mergePatchFacesUndo(double, double, Foam::List const&, Foam::dictionary const&, Foam::List const&) at ??:?
    [27] #6 Foam::autoLayerDriver::mergePatchFacesUndo(Foam::layerParameters const&, Foam::dictionary const&) at ??:?
    [27] #7 Foam::autoLayerDriver::doLayers(Foam::dictionary const&, Foam::dictionary const&, Foam::layerParameters const&, bool, Foam::decompositionMethod&, Foam::fvMeshDistribute&) at ??:?
    [27] #8
    [27] at ??:?
    [27] #9 __libc_start_main in "
    [27] #10
    [27] at ??:?

MPI_ABORT was invoked on rank 27 in communicator MPI_COMM_WORLD
with errorcode 1.
NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.


mpirun has exited due to process rank 27 with PID 7244 on
node exiting improperly. There are two reasons this could occur:

  1. this process did not call “init” before exiting, but others in
    the job did. This can cause a job to hang indefinitely while it waits
    for all processes to call “init”. By rule, if one process calls “init”,
    then ALL processes must call “init” prior to termination.
  2. this process called “init”, but exited without calling “finalize”.
    By rule, all processes that call “init” MUST call “finalize” prior to
    exiting or it will be considered an “abnormal termination”
    This may have caused other processes in the application to be
    terminated by signals sent by mpirun (as reported here).

This is my project link:
https://www.simscale.com/workbench?publiclink=4f85eede-74d6-4168-b964-3687a671bbed


#66

So like someone else, I get the error message when running my simulation:

The job execution was aborted. A possible cause is that not enough memory was available. In this case, selecting a larger instance or using a coarser mesh should resolve the issue.

What am I to do? How did you fix it?


#67

And now it works…at least the mesh generation completed. Started all over in CAESES and created a new rear wing setup


#68

Nice to hear that! It would be great if you could share your results with us!

Since this homework assignements is quite compley we have decided to extended the submission deadline till 17.04.2016