SimScale CAE Forum

Solid materials in CFD project


#1

Hi All,

I’m reasonably competent with FEA but not used CFD before so thought I’d have a go. So I read here that the models have to be solid so I created a ‘room’ in Onshape as a simple extruded rectangle and added near one end another thin upright but long and lowish part (0.1m deep, 1.8m long, 0.6m high) representing a panel radiator - a very simplified version of my lounge. That imported and meshed fine and I set up walls etc as boundaries, the radiator as a heat source and assigned air as the material in the solid. So far, so good. But when I come to run the simulation it wants a material for the second part, except there are no solid materials. If I assign ‘air’ to the radiator part the simulation fails with ‘An error occurred’.

All the tutorials I’ve looked at start with geometry already imported so I’m not clear whether the model is wrong (i.e. should it be two parts?) or did I miss something else. All the tutorials I’ve looked at use the ‘older’ version of SimScale.

If I model the radiator as a void then it’ll allow the simulation to run, but the results don’t make sense (to me anyway).

View link to Onshape: https://cad.onshape.com/documents/9378a51339592b7ae66b4a12/w/77eb088520a425f5f9b6c51e/e/7f679e1fbe816defa6f0fc9b


#2

Hi @irving!

The best would be to share your geometry with us - either the project link and maybe a link to the geometry in OnShape. The @PowerUsers_CFD and I will have a look at it and tell you what you would have to optimize in order to make it work.

Best,

Jousef


#3

Hi @jousefm

I’ve added view link to OnShape in original post and shared with you (can’t seem to share with group though, there are some oddities with mobile browsers)

Best,
Irving


#4

@irving, have you got the CFD project also? you mentioned the results were not as expected if you use the model without the radiator solid? Can you elaborate here? I am interested.

Best,
Darren


#5

Hi Darren @1318980

I’ve linked you to the project. I can’t seem to link the powerusers_cfd group though.

When I said the results don’t make sense it’s because I can’t see a meaningful steady state temperature visualisation, or rather maybe I’m not interpreting it correctly.

What I ideally want to get to eventually is a time-lapse display of how the temperature changes in the room as the radiator goes on and off - so in the simulation I’d like to designate a geometry primitive value as a driver into an external script in MatLab which feeds back as the input variable radiator temperature so I can test fuzzy-logic radiator control algorithms.

Not sure if SimScale supports that (yet).

Best,
Irving


#6

OK, so I found David Heiny’s webinar Session 3 HVAC tutorial and Ali Arafat’s project file for that and tried to replicate that with my own project in Workbench2. In the webinar he ‘imports’ the geometry from OnShape, yet the resulting file is a STEP file rather than a PARASOLID so not sure how that works. Also his ‘model’ shows what appear to be physical walls which don’t seem to get dealt with in the subsequent simulation, they magically vanish leaving just the interior space, However he does model the interior, it would appear, as a collection of voids leaving the ‘air’ space as a complex hollow shell. The heater then is a separate solid in the model but he avoids the ‘material’ issue by designating everything inside the room as ‘air’. Translating that project to Workbench2 reveals that a number of defaults are different but after carefully going through them, including exporting my model from OnShape as a STEP file and uploading it (not that that should hasve an effect) I still can’t get mine to run :frowning:


#7

Hi all, I’m still no further forward with getting this to run. i can run the tutorial at least for a short while. i’ve not seen it get close to convergence as it uses spectacular amounts of processing capacity & time, but my much simplified example fails to get going reliably… :frowning:

More help please.


#8

I will respond propperly shortly @irving

Sorry about this,
Darren


#9

Hi @irving,

This was not your fault, there were several things that worked against you here,

Firstly, you were not warned that the gravity was not defined therefore, there was no movement.

Secondly, upon changing to transient, the steady state time discretisation remained selected, and therefore, correcting the first issue would have lead to more crashes.

this simulation should get you unblocked:

https://www.simscale.com/projects/1318980/room_heater/

note, the simulation is Darrens Transient and is much simplified, simply ramp the complexity from here.

Appologies, and let me know if you need anything else.

Best,
Darren


#10

Many thanks Darren @1318980

I copied your project into my workspace and tried to look at the results of run 6 under “Darrens Transient” but it won’t load the processed results; it tries repeatedly and unsuccessfully to get the results set. I’m now re-running the last sim again to see if it works. I’ll let you know what happens…

Best,
Irving


#11

Hi Darren @1318980

Well I reran the simulation successfully, but i can’t get any results. Post-processing just wont load the results and often just restarts the ‘Loading results, please wait’ barrier itself. Restarting the browser doesn’t help much. Any thoughts?

Best
Irving


#12

Hi @irving, I have had a quick look and seems a download of the results and open in paraview works with the exception of what I believe is the problem cause, an error message detailing a ‘wrong list type for uniform field’, I will let you know when I know more, for the time being can you post process offline and persivear with the error keep popping up?

Best,
Darren