Seismic analysis


#1

Hi,
I’m trying to do the seismic analysis of a tower building, but the analysis always ends with an error.
Does anyone know where I’m wrong?

Attaching the link to see the project
https://www.simscale.com/workbench/?pid=7216604572097262187#tab_1-0


#2

Hi @ale_del_lungo,

Nice project - are you creating a function for the load to ramp it over time? In this case, you need to write in the formula box for example:

-350000*t

Here’s another post that explains the load functions

Best,
Anna


#3

Thank you for the reply,
I tried to insert the function but continues to make a mistake.

From the project I should extract a time history based on the displacement data in function of time.

I also tried to remove the loads but have not solved.

Best,
Alessandro


#4

@ale_del_lungo, Here’s the version I just ran - Let me know if this is what you’re looking for:

https://www.simscale.com/workbench?publiclink=9a8b33a7-5238-47a3-93de-59059ebc1cbc


#5

I tried to edit the data and starting to do the analysis, but also using your link I can not conclude the analysis from my pc

I don’t understand where I’m wrong

Thanks for the attention


#6

@ale_del_lungo, extracting the results you mean?


#7

The purpose is to simulate an earthquake and see the response of the building.

I start the analysis but it always this screen:

and then I can’t do evaluation in post-processor
My problem is that with the settings entered not conclude positively analysis

Sorry for my basic english


#8

Hi @ale_del_lungo,

you can have a look at the project set up by @AnnaFless.

For post-processing visualization you have to switch to the Post-Processor tab and look at Run 4.

Hope that helps!

Best,

Jousef


#9

Hi @ale_del_lungo!

I had a look in to your project. The problem is in interpolation of displacement time in your table upload. After time of 0.995, you directly have 10000. The right hand interpolation only works when you are missing values for certain higher time steps. For example, if you have table only until time 0.995, then running it to 1 sec. will interpolate it.

On the other hand you have 10000 which is quite a huge change and that is also the reason that solver can’t detect the value for t=1 sec. (i.e. your last timestep).

Hope this helps. If you have any question/s, feel free to ask.

Best,
Ahmed


#10

Thank you,
I had seen the work by @AnnaFless
but as soon as exchange of data, such as the constraint conditions in the foundation, the analysis ends with an error

observing the settings used by @AnnaFless I have not found differences so I can not explain that error


#11

@ale_del_lungo - based on the screenshot you’ve shared, you’ve removed the loads?


#12

yes, I’ve tried to remove the loads to see if the problem depended on the applied function


#13

Thank you for the reply @ahmedhussain18
maybe I understand what you mean, but I’m not sure I know enter your information in the program
could you give me more information?


#14

You have to change your data in the file and upload it again. Make sure you have time values in your file with smaller increment until the value you want to simulate.

Best,
Ahmed


#15

Yes, this makes sense - @ale_del_lungo. have a look at the table you have uploaded

The time is at .995 s -> and then jumps to 10000.0 on the next page (seems to be a decimal point problem in the csv file that you uploaded)


#16

Thank you so much
I probably made a mistake when I created the table

Best,
Alessandro


#17

Thanks for your help and for the valuable support @AnnaFless
I try to remake the table

Best,
Alessandro


#18

Some initial results up to .995 seconds :slight_smile:


#19

Work completed!
I fixed the time-displacement table and I did the analysis along the axis x and y with simulation interval 60 seconds

thanks @AnnaFless @ahmedhussain18 for the invaluable assistance

this is the link: https://www.simscale.com/workbench/?pid=7336257124799885652#tab_1-0


#20

Awesome @ale_del_lungo!