SimScale CAE Forum

Rotating fan - no airflow

I’m trying to get particles traces of air around a rotating body. The simulation yielded an error: “Floating point exception”. The result: there is no actual airflow. I checked the boundary conditions and the velocity inlet checks out (10m/s at the right axis). What am I missing?

The project: https://www.simscale.com/projects/glorincz/rotating_fan_1/

That may be the solution:

https://www.simscale.com/docs/content/support/eventLogErrors/floatingPointException.html

“Make sure that for “Compressible” and “Natural Convection Heat Transfer” analysis type, pressure has Non-Zero values in the “Boundary Conditions”, “Initial Conditions” and a Non-Zero “Reference pressure value” is specified under “Numerics”.”

It solved the original problem but the body does not seem to rotate. How can I fix this?

Hi @glorincz!

You have found out to use rotating zones, awesome! Are you sure you want to capture transient effects? If you are satisfied with the steady-state approximation I would personally use the MRF approach with is computationally less expensive than AMI. Let me know if you need a helping hand :slight_smile:

Best,

Jousef

I’ve changed to AMI hoping that I can get the body to rotate. In the simulation I can’t seem to get it move. Maybe it’s something to do with the setup of the simulation?

Hi @glorincz!

You have to create a surface refinement with the cell zone inside option to make it work. Please have a look at this project and the doc entry:


Let me know if there is anything that is unclear.

Cheers!

Jousef

Thanks! I’m following the ‘Rotating Geometries’ tutorial, great source!

I don’t know what I’m doing wrong but when checking the project your kindly shared here, I don’t see any rotation. I’ve added particle traces and the airflow just seems the same as if the rotor was not moving. In this image the airflow clearly swirls around the propeller. Not when I do the simulation. Why?

Rotor clearly moving

The same project: rotor not moving

Hi @glorincz!

Please check your inlet boundary condition. It is not in the direct of the propeller but flowing away from it. I would assume that changing the sign of the flow will correct this mistake. Let me try it myself.

Keeping you up-to-date!

Jousef

That apparently did the job :sunglasses:


Cheers!

Jousef

Thank you! I wonder what settings you used for the particle trace, I still can’t get the swirls.

Not sure what I’m missing but I get this image:

If you could get it work, it means the dataset is correct and the simulation was setup well. Still, the particle traces are straight as a ruler :thinking:

Hi @glorincz!

Just checked it, worked for me using your last valid run. Here are the settings I have used to generate this picture.

Set2


Best,

Jousef

I’ve figured it out: the animation has to be stepped to the second frame. Silly me! Thank you for all the help, @jousefm . I’ve found the tutorials excellent and already signed up to courses on the academy page. Greta stuff!

1 Like