SimScale CAE Forum

Problem with B.C - Empty Boundary Condition


#1

Hi everyone,
I am going to simulate OT.
i was facing some problem with B.C. setup.
B.C. SETUP

  1. i got results with velocity inlet and velocity outlet but the problem in Particle Trace (that not show flowing practical) note: I will improve meshing later.

    2)mass flow rate INLET and velocity outlet (i want with B.C. for my simulation)
    Untitled

can anyone help me?
here is my project link
https://www.simscale.com/workbench/?pid=5991155414810303602&mi=spec%3A2ab67035-f505-4098-b6dc-facbe291de60%2Cservice%3AMESHING%2Cstrategy%3A14&sh=5

thank you,
ROHIT.


#2

Hi Rohit!

I saw that you had a successful run, so did the issue fix itself?

Best,

Jousef


#3

yes, sir, @jousefm there is one successful run on velocity inlet and velocity outlet(B.C.) but the problem with particle trace.
but actually this was not my B.C. i want to simulate this model with mass flow inlet and velocity outlet but when i will run with this B.C. there is some error.
you can see an error in the below image.

thank you,
Rohit


#4

Hey Rohit!

Will have a look at it and get back to you as soon as possible.

Best,

Jousef


#5

Hi @ROHIT_SR

I see that you have done some good work on your geometry(designn2) by removing the double layered structures and making it into a well structured continuous passage for the fluid. Are you still facing some issues. I will be happy to help you with that.

Thanks
Ani


#6

Good hint again Ani!

Rohit, I think you love two layered geometries, right? :smiley: What program are you using for your CAD modeling btw?

Best,

Jousef


#7

HI ANI,
I am still facing this problem. i cant apply mass flow as inlet b.c. and velocity as an outlet. whenever i want to simulate part with b.c. there was one problem. you can see in below picture.
i want to simulated to design with the same b.c. (design 1 and design 2).
can you help me? and also tell me the reason behind this error so next time I will take care.


#8

yes sir :wink:

i am using SolidWorks for cad modelling. but in Solidworks there no any two layered problems(IN CFD). after some time i found out sw not give that accurate results and no use of engineering mind. this is the main reason why I start using SIMscale.
THANK YOU,
ROHIT.


#9

Hi @ROHIT_SR

I ran your case on my system with the B.C’s that you mentioned. It seems to be working in a fine manner.
https://www.simscale.com/workbench/?pid=6870883665423360047&mi=spec%3Aeb653d8f-cf6f-464c-afcb-7d4e0adc3fa4%2Cservice%3ASIMULATION%2Cstrategy%3A6%2Crun%3A6&ps=analysis%2FIncompressible--oneOf%2FboundaryConditions%2F0

If you have any other doubt I would be happy to help you with that.

Thanks
Ani


#10

hi ani,
thank you for your reply.
i just saw your simulation set up. you set mass flow b.c. under the velocity inlet and I applied mass flow rate in custom b.c. and then select flow rate( when i set this b.c. there is an error).

  1. your b.c. set up
    Capture
  2. my b.c. set up

can there is a difference between these two sets up?
can anyone explain why 2nd b.c. set up give me an error? and please explain the meaning of an error also.

Inconsistent boundary condition types. Possibly the empty boundary conditions were not correctly assigned for a 2D mesh. Please check the boundary conditions.

how to set runtime for any particular part ( i am speaking about the amount)
3


#11

Hi @ROHIT_SR

You are conducting a 3d simulation so 2D empty B.C’s are totally wrong for the pressure, TKE and SDR. When you assign 2D empty B.C to any surface, you assume that there is a deviation in the physical quantities along 2 axis only, but it’s not possible to solve this problem as 2D.

I hope you understand that and use the method that I used for this simulation.

Thanks
Ani


#12

HI ANI
thank you for this information :hugs::raised_hands:
for more accurate results I was trying to use a fine mesh and run this setup. and again there is the error.
project link : https://www.simscale.com/workbench/?pid=5991155414810303602&mi=run%3A8%2Csimulation%3A9&mt=SIMULATION_RUN
4
I don’t know the exact amount of relaxation factor(can you explain what exactly relaxation means?) for this model and also please tell me the :point_down:

i am waiting … @anirudh2821998
thank you again
Rohit


#13

Hi @ROHIT_SR

I saw your case and the only possible reason for the failure is the use of the tetrahedral elements(using the new mesh algorithm) for CFD problem. I made another case in which I meshed the geometry using Hex dominant Snappy-hex method and it kind of converged in about 2000 iterations.
https://www.simscale.com/workbench/?pid=5484706381234096424&mi=run%3A9%2Csimulation%3A9&mt=SIMULATION_RUN

@1318980 @DaleKramer @Retsam I think we have got another case in which the new mesh method is causing trouble in convergence.

And to answer the question on what value of max run-time to be assigned for a particular simulation, I always add 2-3 zeroes at the end of the default value depending on the number of element, complexity of the case and the number of iterations.

Thanks
Ani


#14

you always inspire me and share knowledge with your comments.:raised_hands::hugs: Big thank you @anirudh2821998
Rohit.


#15

Hello,
I checked this case and I have a few points which you might find useful:

  • The thin wall adjacent to the outlet (see first screenshot) is the main cause of the simulation results. Removing it improves the results remarkably.
    I ran two simulations using the new mesher, one with the original model and another one with the version without the aformentioned wall. The solution fields are shown in the second and third screenshot respectively. In the first one, the flow is not physical while in the second one results are plausible.



    The probable reason why the Snappy-hex mesh simulation Ani made is successful is that the new mesher respects the geometry of the model while Snappy doesn’t in some cases (e.g. coarse mesh).
    You can see in the fourth screenshot that Snappy smooths out the thin wall at the outlet.
    The new mesher respects the geometry (which is good) but then simulation issues arise.
    I also want to remark that the Snappy mesh has 8e4 cells and took 3 min. while the one with the new mesher has 2e5 cells and runs in 2 minutes.
  • The mass flow at the inlet is quite high and implies a flow velocity of ~85 m/s. At the first elbow of the duct, the velocity reaches 170 m/s which is definitely in the compressible regime.
  • Given the high flow speed, a boundary layer is mandatory to ensure good resolution at the wall. Adding y+ as result control is useful. This variable should be below 300 everwhere for the wall functions to work correctly.
  • The default values for k and omega in the initial conditions are not correct for the velocity of this case. You may want to consider using an online calculator like this one.

Edoardo


#16

I will remove the extruded part.

yes, i was face this problem already.

big thanak you for this information :raised_hands:

thank you,
rohit.


#17

hi everyone,
i want to check velocity across the duct and for that, i was used plot option in post-processor.
but there is some unusual thing was happening.

in the above image, you can see
node 453208 have approx. 11 m/s velocity but in the plot its show 83 m/s.
can i was read plot wrong way?
project link
https://www.simscale.com/workbench/?pid=5991155414810303602&rru=d13fb79a-a95e-4cfd-97a6-ac3629f8884b&ci=20b048c5-1245-4ed6-a653-2a99928d3729&ct=SOLUTION_FIELD&mt=SIMULATION_RESULT
Thank you,
Rohit.


#18

Hi @ROHIT_SR

I cannot see any plot when I open the link. Have you removed them?? It will be a matter of some serious concern if there truly is any such problem with the plot tool as you described.

Thanks
Ani


#19

here is link
https://www.simscale.com/workbench/?pid=5991155414810303602&rru=d13fb79a-a95e-4cfd-97a6-ac3629f8884b&ci=20b048c5-1245-4ed6-a653-2a99928d3729&ct=SOLUTION_FIELD&mt=SIMULATION_RESULT
now its show completely wrong.


#20

Hi @jousefm sir can you please verify from the developers if there is some changes made in the 2D plot viewer as I cannot see any reason behind this problem.

Thanks
Ani